AMD 6470m oddly slow

Anthony_67

Commendable
Feb 15, 2016
2
0
1,510
0
I used to own an HP elitebook 8540p with an i7 620m and a nvidia 5100m, i now bought an elitebook 8460p with i5 2540m and amd 6470m, the thing is, although this card has more shader cores, faster core speed, but slower memory, it performs WAY awful than i expected, league of legends used to run at 120fps on medium to max settings, now it barely run at 50fps on this *equal to better* system, and i cannot figure out why, i tried gta v, it runs smoother, 30 stable fps, better than the nvidia, but league of legendes, even overclocking the card to 850mhz core clock and memory to 1100mhz, it still runs way slower, i cannot figure out why, are AMD cards just this bad? are the drivers just so awful? please help
 
Hi,

The AMD 6470m graphics card should be better than the NVIDIA 5100m. Do try a clean install of the graphics card driver.
- Go to Device Manager and uninstall the AMD graphics driver.
- Open Programs and Features as well and uninstall anything related to AMD.
- Next is to download and install the latest graphics driver form the manufacturers site.
- Here's the link: http://support.amd.com/en-us/download
- Once installed reboot your laptop for the changes to take effect.
- After the reboot make sure to set Nvidia as the default graphics card.
 

Anthony_67

Commendable
Feb 15, 2016
2
0
1,510
0


So,i did this (again,ince i thought of this before) and now i am getting even worst framerate! 35fps on max settings, i can't grasp why! my cpu usage is 19% ad the gpu usage is 99% i doubt it is throttling, the gpu stays cool at 45 degrees celsius. Any lights?

 

ASK THE COMMUNITY