AMD Switchable Graphics Windows 10

zzmejia185zz

Prominent
Oct 24, 2017
1
0
510
0
Hello, I am getting an HP Envy 15 3040nr (https://www.notebookcheck.net/HP-Envy-15-3040nr-Laptop-Review.72051.0.html) and it comes with Intel hd 3000 as well as AMD radeon hd 7690m. It comes with windows 10. I was looking forward to use the amd radeon card for gaming however I have seen many threads and posts about amd switchable graphics not working properly in windows 10 and drivers not working for my card so I was wondering if I should downgrade to windows 8.1 or 7 to ensure that switchable graphics works. Thanks in advance.
 
It should work in 10.

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your AMD graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance AMD processor.

Once it is running on the right one, test the system again and see if the problem persists.


For ATI/AMD graphics cards the process varies.

You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance.

You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.
 
It should work in 10.

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your AMD graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Control Center".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance AMD processor.

Once it is running on the right one, test the system again and see if the problem persists.


For ATI/AMD graphics cards the process varies.

You may need to open graphics then PowerPlay and set plugged in and/or battery to maximize performance.

You can also try going to graphics then 3D and move the slider to performance. Your computer may also have a switchable graphics tab where you can change the settings for individual programs.
 
Thread starter Similar threads Forum Replies Date
Kinomi Laptop Tech Support 2
arcanaxion Laptop Tech Support 1
D Laptop Tech Support 2
S Laptop Tech Support 1
S Laptop Tech Support 3
B Laptop Tech Support 2
A Laptop Tech Support 1
B Laptop Tech Support 6
R Laptop Tech Support 3
F Laptop Tech Support 1
K Laptop Tech Support 1
A Laptop Tech Support 1
3 Laptop Tech Support 1
alexdunker Laptop Tech Support 5
M Laptop Tech Support 1
X Laptop Tech Support 1
N Laptop Tech Support 1
A Laptop Tech Support 2
H Laptop Tech Support 5
S Laptop Tech Support 1

ASK THE COMMUNITY