Question ASUS Q504UA-BI5T26 secure boot violation, none of my googled solutions seem to be working

May 16, 2019
4
0
10
0
So my wife's laptop gets this "Secure Boot Violation - Invalid signature detected. Check Secure Boot Policy in Setup" message this morning, basically not allowing her to start the computer, or at least move past the bios if you hit enter a couple times. I google a few solutions and start running through them when I get home from work. The first one was "Go in disable secure boot and fast boot, and enable csm support". Ok, I do that, boom now I've got a black screen that says "Reboot and select proper boot device, or insert boot media in selected boot device and press a key.

I fiddle with it for a bit, at some point I managed to get to the advanced boot menu or whatnot with F9 (but since, have been unable to access it again even with going through all the steps of the process and trying to replicate where i may of been at the time), so I go create a usb to install / repair windows 10 with, because at this point, the hard drive is still showing in the bios, so I'm not thinking it's bricked on me (usually they just don't appear at all in my experience if that happens). Anyway, i come in and try to repair startup, nothing happens, just get sent back to windows install on reboot, ok, can't do windows restore because of some other unknown error that popped up during that. Great. So I head into the command prompt through the the troubleshooting bar of the install utility and I can't remember what command I looked up at the moment to display the partitions of the hard drive, but everything showed up as normal. Including the ASUS restore partition and whatnot, all listing as health in the cmd prompt.

The bios manager I have on this version looks a bit different though than some of the others I've seen in the various fix tutorials, so the options aren't all the same, and I wanted to see if anyone can maybe help shed some light on the subject because I'm at a loss right now as to what to do. It doesn't seem like a reformat is necessary (though, if it is, then there's another problem, because the windows installation doesn't come with a key on the damn laptop, so the recovery partition is really the only option without me pirating or buying a new copy somewhere.
 

hang-the-9

Titan
Moderator
Sounds like a BIOS option got changed, or there is an issue with the drive. Did you try resetting the BIOS to defaults or checking with the laptop vendor support? For Win 10 the secure boot should be on, also check drive mode that it's set to AHCI and the UEFI boot is enabled not Legacy if your system has that option.
 
May 16, 2019
4
0
10
0
Sounds like a BIOS option got changed, or there is an issue with the drive. Did you try resetting the BIOS to defaults or checking with the laptop vendor support? For Win 10 the secure boot should be on, also check drive mode that it's set to AHCI and the UEFI boot is enabled not Legacy if your system has that option.

Yea, first thing I did after my Googled solution to disable secure boot and fast boot then go into csm failed, I reset it to defaults and it just wenter back into the same secure boot verification error displaying. And the vendor support at asus pretty much was zero help, just giving me the exact same first solution I'd googled, then telling me to send it in after telling me my warranty had expired in January (figures).

Problem I had with other solutions like you're suggesting is that the bios management software on my asus doesn't seem to have the achi or uefi boot modes available when I was hunting around the menus last night, but I'll have another look after work. It seemed like I had a bios similar to other asus platforms, but with less options to change things which was frustrating.
 
Last edited:
May 16, 2019
4
0
10
0
So I got home, checking the shit out and figure maybe updating the bios will help? Nope, because the ezflash bios tool has none of the features shown on the asus website, it just lets me look around the windows recovery drive in which i can't load anything because none of its UEFI bootable. And the kicker is that the Asus website has garbage support for this model apparently, with a bios version listed for download as version 302, while the one on my laptop is 304.

Laptop is an asus Q504UA model, (also, strangely unable to find it while searching through the asus laptops, but somehow it came up on the driver search page. I have to post links to the gdrive images because the forum won't allow me to link images directly it would seem.

Here's where it starts.
https://drive.google.com/open?id=1-1aLdjN3PJxhMg1bLHoGIJfMGoqev0c1

And this is what the front of my bios looks like (a bit different from the asus bios screens i see smattered all over the web.
https://drive.google.com/open?id=1-7bS1HqN6ee5p7ZCMEkZjByHOaOQ8zFF

I then head into the advanced tab
https://drive.google.com/file/d/1-8HAwlY2qH8EhURgknqAwSXl40kSW0-5/view?usp=sharing

The advanced portion of the advanced tab (seems redundant), the washed out one i have highlighted is just intel virtualization technology.
https://drive.google.com/file/d/1-Lt063BHQBvhRMEWL-ywbregtpAgOGbH/view?usp=sharing

The ezflash utility options is basically just something to access a connected device with, it doesn't contain the more sophisticated internet update option that i saw shown in other tutorials with what i can only guess are newer or better versions of my bios.
https://drive.google.com/file/d/1-uUE98i3vywbypn-uakFe2KEhK4soeCY/view?usp=sharing

Boot options (washed out one is Fast boot, enabled by default)
https://drive.google.com/file/d/1-PhjVp1XfBVNXtc690dvBvrEagLld8at/view?usp=sharing

Security options (washed out portion is Administrator password)
https://drive.google.com/file/d/1-V7ZR-NE5V71j6Qla7BQg5PHXoRYPsl6/view?usp=sharing

Secure boot section (washed out section is just to move back / up a level in the options)
https://drive.google.com/file/d/1-jD49FxKOi2xvViW_pHwiGTKrl8hQsYr/view?usp=sharing

If I follow the basic internet fixes for the initial problem that presents itself, I wind up here. Those steps are > Disable Secure boot, Disable Fast boot, Enable CSM etc.
https://drive.google.com/file/d/1-lDPYZbaC4S_EmGMfv1EbY1bYCuNQ3m9/view?usp=sharing

And my bios screen has this new drive listed (which isn't really a new drive, it just isn't going into the windows boot manager anymore.)
https://drive.google.com/file/d/1-s2IRAA7h9Ic98BMFwEwVZg6dsr-YSoF/view?usp=sharing

Now, if I boot from a usb thumb drive with windows I am able to get into windows 10 install process to fool around with some extra tools, but startup repair didn't really seem to do anything, and recovery doesn't work. But if I list the partitions in the command prompt from the windows install troubleshooting menu, it shows me everything as being healthy.
https://drive.google.com/file/d/1-x4wR5o5BW5lK-m-AafG_v5bgiszdc-x/view?usp=sharing

Now I also thought maybe uninstalling the latest windows update could do something, but alas, when I try that it says I have pending updates and to use startup repair instead, which goes to restart > diagnosing problems > attempting fix (for about 1 second) and immediately back into the windows troubleshooting screen, wherein if I go back and reset my bios to default from here i find myself in the secure boot violation again.

So again, I try something else. Going back to try and booting from the thumb drive after resetting my bios options and something new comes up in the windows repair / troubleshooting settings.
https://drive.google.com/file/d/102GbkRAtq65k-zs2rbB_NgxrJNexFgsK/view?usp=sharing

Before with secure boot disabled, the UEFI firmware settings option didn't showup, and clicking it tells me i need to restart my computer to do it. So I do, and it sends me strait into the bios which isn't too surprising. But I still don't see anything about UEFI settings anywhere, or making sure something boots as such. The only thing that shows up as UEFI in my bios now is the flash drive i have for installing windows. Boot option 1 is still the windows boot manager, while 2 is the flash drive, so the boot manager just doesn't seem to be kicking in.

If I remove the flash drive and reboot at this point, I just go back into the Secure boot violation screen, if I leave it in, it of course loads the windows 10 install startup.

I'm at a complete loss as to what could be going on, I'm used to dealing with desktops and I've never had this kind of issue with one.
 
May 16, 2019
4
0
10
0
Whelp, guess nobodies got any ideas. Guess it's time to see if I can get this hd out of the laptop and hook it up to my desktop to backup the files before sending it somewhere to overpay someone to fix it. :/
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 0
Paul Wagenseil Laptop Tech Support 0
henrytcasey Laptop Tech Support 0
P Laptop Tech Support 0
P Laptop Tech Support 0
M Laptop Tech Support 0
J Laptop Tech Support 1
C Laptop Tech Support 1
R Laptop Tech Support 1
O Laptop Tech Support 1
R Laptop Tech Support 0
V Laptop Tech Support 3
D Laptop Tech Support 1
R Laptop Tech Support 1
0 Laptop Tech Support 1
H Laptop Tech Support 2
A Laptop Tech Support 2
F Laptop Tech Support 1
K Laptop Tech Support 2
M Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS