Question asus zephrus g 502 DEAD

Jun 13, 2020
1
0
10
0
my laptop will not power on at all. Power button does not power the laptop. USB outlets do not provide external power (tried charging my phone). None of the indicator lights are functioning.

Prior to laptop going dead I did the following things that may give us some clues as to what may have happened....

My mumble clients ppt feature was malfunctioning so I decided I would update it and restart my computer. I successfully downloaded and installed the latest mumble client and additionally decided to clear my cache using the asus rog armory software... i also changes the wallpaper of my laptop lol and then proceeded to restart my computer.

I swear I pressed "restart" but my laptop powered off did not perform a restart. I then powered it back on myself as I would normally and the laptop booted normally... i thought it was weird that it hadn't restarted like I told it to so I tried it again. "Restart". It did the same thing, powered down and not reboot. I tried to turn my pc back on using the power button but this time it was totally dead in the water. Zero response ahat so ever. No power, no indicators, no power to usb. Nothing.

I opened the laptop, disconnected the battery pack as well as the cmos battery. Disconnected the power jack and did the usual "press and hold power button trick" to rid static build up and hard reset the components. Still no power... what in the world may have gone wrong? I'm usually pretty tech savvy and troubleshoot my around the pc pretty well but I cant do anything if the thing doesn't even have power! asus customer support is closed atm and I will get in contact with them asap. But any suggestions?
 

ASK THE COMMUNITY