Blue Snowball suddenly not picking up any sound?

Status
Not open for further replies.

Leetal

Prominent
May 19, 2017
2
0
510
0
Hello!

I have been using my snowball for a very long time with no problem. Suddenly, one day, my snowball is not showing any signs of picking up sound on my pc. When I plug my snowball into my laptop, it works fine. When i plug my snowball into other usbs on my pc(which definitely work, because i can plug my webcam into certain usbs and the microphone from my webcam picks up sounds fine) it still picks up no sound. My computer fully recognizes it, making a sound when it is connected/disconnected. The snowball lights up to show it is connected. This is a computer related or windows 10 issue, I just can't figure it out at all...I have no idea why this is happening.

The snowball is set to default device and there is no sound picked up even when i set it as default on any program. The bars that pick up sound in the sound manager are not moving. Any of the basic stuff is ruled out. Anyone have a clue? Please help :( Thanks!
 

Herc08

Respectable
Aug 6, 2016
236
0
1,910
45


You can try different USB ports. Also try to re-install your audio driver. Just go to Device Manager, select your audio driver and uninstall it (do not remove the software). And then restart the computer. Windows should re-install it, and it should work agian.
 

Leetal

Prominent
May 19, 2017
2
0
510
0


I've tried different USB ports, which I know work so that's not the issue. I will try to reinstall my audio driver and update. Thank you!
 

Double0Justin

Commendable
May 13, 2016
1
0
1,510
0


I am having the exact same issue, have you found a solution for it?
 

zacknottke

Prominent
Oct 10, 2017
1
0
510
0




yeah same ive tried everything and no solution its really starting to piss me off too. :(
 

jayisbay0526

Prominent
Nov 2, 2017
1
0
510
0
:/ I can't even call my friends on discord, I have to yell into the mic while my mouth is against it to make sound. Just yesterday it worked just find. Anyone got a solution that i haven't tried yet?
 

cmurf162

Prominent
Jan 8, 2018
1
0
510
0
Literally EXACT same thing. Yesterday it was fine and now nothing! Recognizes device but doesnt pick up any sound. Its pissing me off already!
 

lethalshark

Honorable
Jan 18, 2014
25
0
10,590
1


I just had the issue issue today and I managed to fix it for myself. I went to drivers and deleted not only the Blue Snowball under "Audio inputs and outputs" but also blue snowball under "Sound, Video and game controllers" down below. After deleting both I unplugged the snowball then plugged in back in and it asked me to restart to finish setting up installing. After restart it worked again. Tell me if this works for you.
 
Feb 27, 2018
1
0
10
0


This worked thank you very much :D

 
Status
Not open for further replies.

Similar threads


ASK THE COMMUNITY

TRENDING THREADS