Buzzing noise in A40 Mixamp

Johnson Deng

Estimable
Jan 2, 2015
3
0
4,510
0
This issue has happened recently, it started on the 17th of August and at first I didn't notice anything until I turned up the volume, then I could clearly hear the buzzing noise. I've followed all of Astro's troubleshooting tips and the only thing that has worked for me is unplugging my headset from my power outlets in my room.

This is strange because the day this buzzing started happening was the day my computer problems started. Basically my computer turns on but turns off after getting to the Windows icon and then I won't be able to turn it on until I've replugged it. At first I thought it might be a motherboard, RAM, or PSU issue but I have now replaced my motherboard and processor and my RAM is less than 4 months old but I still get the same issue. I even have a new case and I've tried using a different power cord, I've also tested all my peripherals on my laptop and they work fine. I concluded it must be my PSU but my question is that could my power outlets be the cause of my computer problems?

If so where do I go from here? Call an electrician? The buzzing in my headset only stops when it is not drawing power from the power outlets in my room.
 

Johnson Deng

Estimable
Jan 2, 2015
3
0
4,510
0


I have a Cooler Master V750 - Compact 750W 80 PLUS Gold Modular PSU.

I'm currently using my headset on my laptop and I can also hear the buzzing though, it only stops when I disconnect the power cable from the outlet. There is no buzzing sound when its just my laptop battery. Leads me to think there is something going on with the outlets/electrical wiring.
 

basroil

Honorable


Not exactly an excellent unit, but should be good enough to not cause buzzing.

Have you tried using a different AC adapter for that mixamp? Could be as easy as just a broken AC power supply for it.
 

Johnson Deng

Estimable
Jan 2, 2015
3
0
4,510
0


The headset is USB powered, like I already mentioned the buzzing is heard even on my laptop. My PC does not work currently, the only time the buzzing is gone is where there is no connection between it and the outlets. If I disconnect the power plug from my laptop and just run with the battery there's no buzzing.
 
Thread starter Similar threads Forum Replies Date
N Audio 0
Wowee3 Audio 0
A Audio 0
Godwin123321 Audio 0
C Audio 4
J Audio 1
A Audio 3
P Audio 0
I Audio 4
D Audio 3
F Audio 3
L Audio 3
J Audio 3
L Audio 4
L Audio 7
T Audio 3
P Audio 1
S Audio 1
R Audio 4
J Audio 9

ASK THE COMMUNITY