can't access bios


Jun 23, 2014
Turned off my computer with everything ok. Next time I turned it on The black screen with notation saying to hit F2 or Del to go into bios and then froze. From then on every time I boot the same thing happens. The screen freezes and it takes a minute to eventually boot from this screen into Windows 7 Pro without ever letting me go into the bios to get out of the problem. After it finally boots to the desktop it then takes about another minute for the mouse to unfreeze and start to work (mouse is wireless). I have not made any changes to my computer recently. It is really frustrating! The build is around 4 years old. Below are the specs on this machine. Windows did add one of their "important" updates the other day (KB4503548) which is framework 4.8 for windows 7 for 64. It was listed as installing successfully but still lists it in my updates each time to be installed as if it weren't already installed - it is the same KB number of the one installed. I did change out the MOBO battery which didn't make any difference. Thanks in advance for any help someone might be able to offer.

CPU: AMD 3.70 GHz
Motherboard: Asus A88X-Pro
Ram: 8 GB
PSU: 60 W Antec
Chassis: Corsair Tower 200R
OS: Windows 7 Pro
Monitor: HP Wide 2009m
I built this unit approximately 4 years ago


This would be a better question for Tom's Hardware.

Thread starter Similar threads Forum Replies Date
SirDeafCheese Laptop Tech Support 5
F Laptop Tech Support 2
D Laptop Tech Support 8
Iangogo:) Laptop Tech Support 6
Jukeman_IronWulf Laptop Tech Support 1
VJK Laptop Tech Support 1
J Laptop Tech Support 0
P Laptop Tech Support 6
IC_Dev Laptop Tech Support 0
Coldheartednite Laptop Tech Support 8
P Laptop Tech Support 2
N Laptop Tech Support 0
N Laptop Tech Support 3
L Laptop Tech Support 0
B Laptop Tech Support 1
vhenzo Laptop Tech Support 0
C Laptop Tech Support 2
H Laptop Tech Support 1
E Laptop Tech Support 2
B Laptop Tech Support 2
Similar threads
Question laptop turns on but after 2-3 seconds no fans, no keyboard led, no display, but power led still works, I cant access to BIOS
Question Can't Get Internet Access with Hotspot
Question Can't access boot/BIOS menu onToshiba Satellite P875-S7200
Solved! no internet access from ethernet
Solved! Acer Nitro 5 AN515-53 Black screen, no logo, no windows boot, and can’t access bios
Solved! Why does my laptop have internet access only when it is connected to phone's hotspot and not when it is connected to a normal wifi?
Question No internet access on one device via wifi (ethernet works only)
Solved! Unable to access the boot configuration Toshiba Satellite P875-S7102
Question Dell Inspiron stuck at DELL logo and can't access BIOS please Help!!!
Question Ethernet connected but getting "No internet access"
Solved! Unable to locate internet location
Question Query: How to access and replace the CMOS battery in the Compaq Presario 2700 laptop
Question Laptop died, OS partition (C:) missing when accessed via usb
Question Need to access (remotely or not) to my computer
Question I connect to the internet but I can not access !
Question operating system not found as bios cant access
Solved! is there a way to gain access to my Toshiba Satellite L455-S597 if i don't remember the user password?
Solved! Use Laptop to access Headless CPU??
Question Can not open or any other IP addresses (inside Network) + no Network discovery
Question Laptop connects to WiFi but can't access internet