can't access bios

Seeking

Honorable
Jun 23, 2014
3
0
10,510
0
Turned off my computer with everything ok. Next time I turned it on The black screen with notation saying to hit F2 or Del to go into bios and then froze. From then on every time I boot the same thing happens. The screen freezes and it takes a minute to eventually boot from this screen into Windows 7 Pro without ever letting me go into the bios to get out of the problem. After it finally boots to the desktop it then takes about another minute for the mouse to unfreeze and start to work (mouse is wireless). I have not made any changes to my computer recently. It is really frustrating! The build is around 4 years old. Below are the specs on this machine. Windows did add one of their "important" updates the other day (KB4503548) which is Microsoft.net framework 4.8 for windows 7 for 64. It was listed as installing successfully but still lists it in my updates each time to be installed as if it weren't already installed - it is the same KB number of the one installed. I did change out the MOBO battery which didn't make any difference. Thanks in advance for any help someone might be able to offer.
Seeking

CPU: AMD 3.70 GHz
Motherboard: Asus A88X-Pro
Ram: 8 GB
PSU: 60 W Antec
Chassis: Corsair Tower 200R
OS: Windows 7 Pro
Monitor: HP Wide 2009m
I built this unit approximately 4 years ago
 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 2
M Laptop Tech Support 6
P Laptop Tech Support 1
James T Kirk USS Enterprise Laptop Tech Support 6
Jeffery2084 Laptop Tech Support 7
N Laptop Tech Support 5
H Laptop Tech Support 1
nachicocce Laptop Tech Support 1
F Laptop Tech Support 1
Aquaeyez Laptop Tech Support 1
B Laptop Tech Support 1
1 Laptop Tech Support 2
W Laptop Tech Support 1
K Laptop Tech Support 1
T Laptop Tech Support 4
C Laptop Tech Support 1
E Laptop Tech Support 1
K Laptop Tech Support 1
J Laptop Tech Support 1
S Laptop Tech Support 1

ASK THE COMMUNITY