Clevo laptop not booting

ferdibarda

Commendable
Jan 14, 2017
2
0
1,510
0
Hello,

I was working on my laptop on battery when it suddenly shut down after I moved it.

Now everytime I press power, the button light turns on and I can hear the little noise as usual but it doesn't boot (black screen, no sounds).
It's like that for about 30 seconds and then I can hear the fan running for about 10 seconds and then it just shuts down.

I tried removing battery + unplugging and pressing power for 60 sec but the result is the same.
I also tried removing the RAM and the SSD (alternatively and both) but same thing.

If I don't find anything more to do I'll go to a repair shop on Monday. Any advice ?

Thanks in advance.
 

ferdibarda

Commendable
Jan 14, 2017
2
0
1,510
0


Yes, when the charger is connected to the laptop the charge light is on. The battery was almost fully charged. I tried it with the battery only, with the charger only or both...
 
Thread starter Similar threads Forum Replies Date
R Laptop Tech Support 1
T Laptop Tech Support 2
H Laptop Tech Support 1
G Laptop Tech Support 3
N Laptop Tech Support 8
NOOB2PRO Laptop Tech Support 1
V Laptop Tech Support 5
YeOldTurnip Laptop Tech Support 33
D Laptop Tech Support 1
B Laptop Tech Support 3
M Laptop Tech Support 3
A Laptop Tech Support 2
L Laptop Tech Support 2
K Laptop Tech Support 3
W Laptop Tech Support 1
R Laptop Tech Support 1
1 Laptop Tech Support 2
F Laptop Tech Support 6
L Laptop Tech Support 2
SKIPPY PB Laptop Tech Support 4

ASK THE COMMUNITY