Question Dell e7440 Laptop won’t turn on(flashing battery led)

Mar 25, 2020
2
0
10
0
I have a Dell e7440, I haven’t booted it on in a while but when I try charging it, it turns on with the fan and everything for a second then shuts off. Powering it on the power led stays on for a few seconds then shuts off and all the other led lights stay on with the battery led flashing, minutes later they turn off. I tried leaving it to charge for the whole day and the same thing happens with the charger in and out of the laptop. I suspected something must have been wrong on the inside, I tried running the laptop without the cmos battery and still got the same thing I also tried taking out the ram sticks and hard drive and still got the same thing. Anyone have any suggestions on what I could try?
 
Mar 25, 2020
2
0
10
0
My dell e7440 won’t turn on with 2 ram sticks in but the fans and LED lights work for a few seconds after turning off. When I try taking out the ram on the 1st slot the laptop boots up but the fan doesn’t spin. There seems to be something wrong with the 1st slot, I’ve tried both sticks on slot 1 but it still doesn’t work. Any help ?
 
Thread starter Similar threads Forum Replies Date
Roger- BiTNET Laptop Tech Support 0
P Laptop Tech Support 0
Roger- BiTNET Laptop Tech Support 0
O Laptop Tech Support 0
T Laptop Tech Support 0
R Laptop Tech Support 0
aparky42 Laptop Tech Support 1
nrmndv Laptop Tech Support 0
Edu2k Laptop Tech Support 5
cesc4 Laptop Tech Support 1
Tsaadlorsh Laptop Tech Support 0
L Laptop Tech Support 0
Gabrieldd7 Laptop Tech Support 3
S Laptop Tech Support 5
A Laptop Tech Support 2
G Laptop Tech Support 1
B Laptop Tech Support 2
R Laptop Tech Support 6
P Laptop Tech Support 1
H Laptop Tech Support 4

ASK THE COMMUNITY