Question Dell vostro doesnt boot not even to dell logo or bios

Nov 25, 2020
1
0
10
0
I have a Dell Vostro 5470 2 years old but works fine, last night I decided to upgrade it. I switched the ram with an 8g stick ddr3l 1600mhz and also switched the HDD to a 250ssd and everything worked out fine I installed win 10 and all the drivers I even restarted it few times not a single issue.
The day after, it doesn't want to boot the power button lights up for 2 secs and the goes dead and not a single thing on the screen, I replaced all the parts with the old ones and nothing did the discharging thing with the switch between battery and ca, nothing. Disconnected the CMOS battery and still nothing. Please help I really need this laptop to boot
 

AlHuneke

Prominent
Jul 7, 2020
372
36
540
39
Did you take anti-static precautions when you had the machine open? If not, you risk damaging parts. I'm not sure what you mean by "discharging thing". Please elaborate. Also, removing the CMOS battery just risks losing BIOS setting that you need for proper operation as all the settings will return to the defaults (which is probably OK).

When you plug in external power, does the charging LED come on? What you are describing sounds to me like a the battery is discharged and the external power is not working.
 
Thread starter Similar threads Forum Replies Date
MS-08th Laptop General Discussion 2
ali.mkhm Laptop General Discussion 0
C Laptop General Discussion 1
V Laptop General Discussion 5
A Laptop General Discussion 1
amitk97 Laptop General Discussion 2
G Laptop General Discussion 1
O Laptop General Discussion 2
S Laptop General Discussion 2
S Laptop General Discussion 2
G Laptop General Discussion 1
B Laptop General Discussion 1
C Laptop General Discussion 4
R Laptop General Discussion 1
M Laptop General Discussion 1
C Laptop General Discussion 2
D Laptop General Discussion 2
J Laptop General Discussion 2
A Laptop General Discussion 3
A Laptop General Discussion 4

ASK THE COMMUNITY