Dec 31, 2007
I am henseforth a dumbass. I have made one of the stupidest mistakes and believe others that share my stupidity may also slap themselves in the head when they read this. First let me explain me setup, then the problems I was noticing, and finally the answer to <font color=red>all</font color=red> of the problems I have been enduring.

I have two nice machines (at least they are now) and compared them to a control machine, a Gateway Select 1100 that was another machine at work.
I have yet to overclock my gaming machine and never my work machine so these setups and scores are stock.

1: My gaming machine

AMD 1000 MHz 200MHz FSB stock fan
256MB generic PC133 SDRAM (2 DIMMS)
ASUS A7V BIOS ver 1005a
Maxtor 40GB 7200RPM HDD
Leadtek Winfast GeForce2 GTS 64MB DDR
SBLive Platinum ver 5.0
Creative labs 5X DVD w/dxr
YAMAHA 16x/10x/40x Burner
INWIN case with 300W P/S

2: My Workstation (actually my boss'es, but I built it and maintain it)

AMD 1000MHz 200MHz FSB Coolmaster DP5-6H11
256MB Mushkin REV2
IBM Deststar 45GB 7200 RPM HDD
Diamond Viper V770 Ultra 32MB
On board audio
Mitsumi 32x CDROM

3: Gateway select 1100
AMD 1100MHz 200MHz FSB stock fan
some MSI socket A board specific only to Gateways
512MB Generic CAS3 SDRAM (2 Dimms)
GeForce2 Ultra 64MB DDR
IBM Deskstar 45GB 7200 RPM HDD
SBLive Value
Promise Ultra ATA 100

Now Besides the SBLive the first two machines have similar setup as far as drivers go and the A7V and the Gateway can share the same Promise drivers. So here's a list of what I was using for both machines.

Windows Professional Service Pack 1
AMD AGP reg Patch
VIA 4in1 425a
Detonator 6.18 thru 7.52 BETA
DirectX 8.0a with mouse reg patch
Promise U100D160B25 (for the A7V and the Gateway)
The Gateway was running drivers it came with except the SP1 and the AMD AGP reg patch.

Ok now on to the problems.
I'm always interested in how fast these machines are compared to others so I downloaded 3DMark2000 to see. I was very disapointed to see that these machines scored very low compared to others online. Infact the workstation scored the highest of the two at only 3800. With a little look at different detonator drivers I got it up to 3900. Now that was ok compared to online scores considering it had a TNT2 although still a little low, but the gaming machine with the A7V and the GeForce2 was only 3200 MAX!!! The Gateway however was impressive (at this point anyway with a score of 4300.) Now this made me very angry. Plus, the damned A7V based machine would not run Unreal Tournament in Direct3D. The mouse lag was horrible. So I installed it on the workstation and had the same horrible mouse lag. The A7V also took a long time to pass the splash screen. This, though, was a problem I learned to live with since I am pretty patient. Up to this point both machines had DirectX7. So I decided to install DirectX 8.0. Both machines still did not change. I then saw a mouse reg patch on Microsoft's site and installed it on the machines. It still didn't work but did help the workstation a bit. I then switched Detonator drivers to 6.50. The workstation then worked like a charm in UT, but the gaming machine did not. I was wondering if it should be called a gaming machine at this point. Now the workstation was scoring about 4300 and the gaming machine was up to 4100. So I decided to tackle the gaming machine and leave the workstation alone since I was happy with it now (especially since it was as fast as the Gateway and although both were perchased at the same time the one I built was a third the price). I had Generic RAM in my gaming machine and noticed how CAS2 RAM helped the workstation beat the Gateway so I decided to buy new RAM for the gaming machine and also a USB mouse (Microsoft Optical). For the RAM I got 256MB Micron CAS2 ver 7E (for only $110 at that). I did notice an increase in the benchmarks as it was now beating the workstation and the Gateway @4444. But the UT problem persisted. I then go to Epic games web page and find a DLL for the GeForces that supposedly helped solve what seemed to be my problem, but remember my stupidity was my problem. This did not solve my problem. So at the advice of a friend I decided do reinstall Win2k and start from the ground up back from DirectX7 and install and test driver by driver every change I make. It is now that I start on the endeavor that solves the problem.
Ironically it was not during the installation but the backup process where my problem would show it's solution. I burned on CD all my games and files (about 17GB). Needless to say this could get expensive so I Zipped the directories of some games so that some would then fit on a single CD. Well I reformatted and partitioned the drive and Win2k installed easily. I then grabbed the one CD that had a Zip'd game I wanted to put back on the computer. Now this game had directories and all so when it was Zip'd all the directories turned to paths, but were not store as such in the Zip window when I click on the Zip file. I selected all the files in the window and dragged it into the directory I wanted. "Hey", I noticed. All the files were in the same directory and not in their respective directory. I went back into the zip file and decided for the first time to use the extract command. Hello, directories are now there and files are in them as well. As I stared at the screen the gears in my head started to grind... I wonder... Some of the drivers I download are in zip format... Hmmm... Lemme check to see what drivers are zip'd. I find that the Promise drivers and the Via 4in1 drivers are zip'd with directories. What does this mean?? Well when I clicked and dragged I noticed a prompt came up that would ask to overwrite files. (stop laughing) Well I figured this was some wierd bug so I clicked ok and went on. This also means that I was using a mix of Win2K Win9x and WinNT drivers on the Win2K machines I built. I have been building my own machines for four years, downloading drivers for one, and benchmarking for 2 months and have never bothered to learn what the extract botton does in Winzip.
So did it work?? Better than I could've dreamed. The workstation now scores 4920. And the gaming machine? Well after a short boot up and after it ran well in UT @1600x1200 I decided to use Detonator3 7.52 BETA and Via 4in1 425a it scored 5333 on lowest res Athlon enhanced and oddly 6895 using default settings at default res using D3D optimization (go figure, it even gets lower scores at lower res). Am I stupid or what?? I guess the only credit I can give myself is for at least solving the problem, but still...
Now I have solved what seems to have been a performance curse that has been plaguing me. I will upgrade the CPU fan to a Swifttech cause performance creeps down when its on for long periods of time and I'll finally start to overclock since now I can see some real results. I belive I have made a great sacrifice, embarrassing myself, for the benefit of any other poor sap who makes the same idot mistake. I deserve all flame and ridicule and formally ask for the web master of this forum to permanently change my title to Dumbass.

PS the workstation's UT fix was that the Detonator3 driver had to upgraded due to the fact it was a TNT2 as was said on Epics page.

<font color=red>Take my advice with a grain of salt, for</font color=red> <font color=blue>I AM A DUMB-ASS!!!</font color=blue>