Solved! Graphics programs

MBA380

Great
Nov 1, 2019
17
2
75
1
Hello!

I've been trying to end all processors that run on my graphics card (because I mostly use my laptop unplugged and the gtx 1050 eats up my battery really fast) but theres this one processor that keeps popping up... YourPhone.exe has been annoying the crap out of me, I've went into the folder that its located in and tried to change the settings on my graphics control panel so that it runs on my internal gpu but had no luck with that, then tried to end the processor everytime (and stop it from running on bootup, forgot how I did it but then it kept coming back up anyways) which actually worked. After the latest update another processor popped up that was called:
WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe

Now I'm all out of options, did the same thing with the control panel where I tried to force it to my internal gpu but still nothing.. I saw that in the folder of its location there was something similar to "phone"...

How can I stop those processors from running on my dedicated gpu?!

Thanks in advance!

EDIT:
I've found out a solution to the WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe task, turned out its the touch keyboard and I have no idea why it was running in my dedicated gpu haha. I disabled it by this command in the admin cmd:

reg add "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe" /v Debugger /d "%SystemRoot%\system32\systray.exe" /f

taskkill /im "WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe" /t /f

echo done

but I'm still having no luck with the YourPhone.exe program..
 
Last edited:

Ill91

Great
Jun 13, 2019
11
0
60
1
Hello there, I'm Ilias, a computer enthusiast since 2009, and would be more than glad to assist you today.

YourPhone.exe is a Microsoft program which comes with the OS. It communicates with your desktop to your phone, if your Microsoft Account it setup to do that. Take these following steps to disable the program entirely if it is not to your use.

  1. Open the Settings App > Go to Privacy > Background Apps Risky link removed by Moderator in the list, click on it and then select Advanced options
  2. Then toggle off the option for Background apps.
It is strange that YourPhone is running on a dedicated GPU, however disabling it in the background should help.

Cheers. Reply with updates.
 
Last edited by a moderator:

Ill91

Great
Jun 13, 2019
11
0
60
1
Hello there, I'm Ilias, a computer enthusiast since 2009, and would be more than glad to assist you today.

YourPhone.exe is a Microsoft program which comes with the OS. It communicates with your desktop to your phone, if your Microsoft Account it setup to do that. Take these following steps to disable the program entirely if it is not to your use.

  1. Open the Settings App > Go to Privacy > Background Apps Risky link removed by Moderator in the list, click on it and then select Advanced options
  2. Then toggle off the option for Background apps.
It is strange that YourPhone is running on a dedicated GPU, however disabling it in the background should help.

Cheers. Reply with updates.
 
Last edited by a moderator:

MBA380

Great
Nov 1, 2019
17
2
75
1
Hello there, I'm Ilias, a computer enthusiast since 2009, and would be more than glad to assist you today.

YourPhone.exe is a Microsoft program which comes with the OS. It communicates with your desktop to your phone, if your Microsoft Account it setup to do that. Take these following steps to disable the program entirely if it is not to your use.

  1. Open the Settings App > Go to Privacy > Background Apps
  2. Find Your Phone app in the list, click on it and then select Advanced options
  3. Then toggle off the option for Background apps.
It is strange that YourPhone is running on a dedicated GPU, however disabling it in the background should help.

Cheers. Reply with updates.
Hello!

The application is disabled in the background apps but it keeps starting up, along with the WindowsInternal.ComposableShell.Experiences.TextInput.InputApp.exe.

Its really annoying and I can't find any other way to stop it from running or to atleast make it run on the integrated gpu instead...
 

MBA380

Great
Nov 1, 2019
17
2
75
1
I removed that link because mentioning it would have been adequate.

@op If you still have a problem with that file, try changing its name by a couple of letters..
I dont want to disable the app, I just want to make it run on my integrated graphics and if thats not possible then disable it from running on startup, not permanently.
 

MBA380

Great
Nov 1, 2019
17
2
75
1
Sorry for the twenty four hour delay but it's a busy weekend for me.

You should be able to prevent it starting at boottime in Task Manager under the Startup tab.
Alright, thanks a ton and sorry for disturbing your weekend :p

I was able to fix it by doing what Ilias said in combination with your answer and a restart to make sure its working properly.

Thanks!
 
Thread starter Similar threads Forum Replies Date
spike4379 Laptop Tech Support 2
baltay Laptop Tech Support 0
D Laptop Tech Support 6
M Laptop Tech Support 0
Kaiavatar Laptop Tech Support 8
F Laptop Tech Support 5
L Laptop Tech Support 22
O Laptop Tech Support 3
G Laptop Tech Support 10
C Laptop Tech Support 6
R Laptop Tech Support 3
D Laptop Tech Support 3
N Laptop Tech Support 14
aakarshan Laptop Tech Support 1
G Laptop Tech Support 3
J Laptop Tech Support 16
N Laptop Tech Support 3
memoooo500 Laptop Tech Support 7
G Laptop Tech Support 3
L Laptop Tech Support 6

ASK THE COMMUNITY