Question Ground Wire hum- do I need a replacement?

Sep 14, 2020
2
0
10
0
Hi there!
I’m running the triangle BR03s through an IOTAVX SA3 with a Fluance RT85 and haven’t had any grounding/hum issues until last night. There is a persistent hum and significant buzzing/crackling upon adjusting the clamp or the end of the cable only on the end where it meets the amp. There’s no humming or buzzing when it’s connected to Bluetooth. I have both the TT and amp plugs connected to a surge protector power strip but have also tried directly into the wall. Does this mean it’s an internal wire issue and I just need a new ground cable?
 
Sep 14, 2020
2
0
10
0
I’m running triangle BR03s through an IOTAVX SA3 with a Fluance RT85 and haven’t had any grounding/hum issues until a few nights ago. There is a persistent hum and significant buzzing/crackling upon adjusting the clamp or the end of the wire mostly on the end where it meets the amp and some where it’s grounded to the TT. There’s no humming or buzzing when it’s connected to Bluetooth, though. I have both the TT and amp plugs connected to a surge protector power strip but have also tried directly into the wall. I feel like I’ve tried everything- adjusting the headshell, unplugging and replugging everything, even getting another ground wire. I’m just not sure how to identify if it’s a turntable or an amp problem (doesn’t seem to be the wire itself considering I tried a totally different one but I wouldn’t rule it out) and then go forward with a solution. I’ve been told it’s an oscillation issue but not sure where to start with fixing that! Link to videos here
 
Thread starter Similar threads Forum Replies Date
R Audio 4
djrakobeat Audio 2
0 Audio 1
D Audio 3
J Audio 1
Y Audio 5
G Audio 1
R Audio 6
T Audio 6
C Audio 4
M Audio 10
L Audio 5
B Audio 1
M Audio 2
D Audio 1
O Audio 1
D Audio 1
yanis31 Audio 2
H Audio 1
D Audio 7

ASK THE COMMUNITY