Headset not detected after plugging to my PS3 with HDMI

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
Hello

I no longer can hear anything with my headset since I used it on my PS3 today, using the same HDMI cable that I was using with my PC monitor.

Headset: Steelseries Siberia 840

tl;dr:
My headset was working before with this setup:
Headset USB ---> PC
Monitor screen HDMI ---> PC
My headset stopped working after using the HDMI cable on my PS3 because now it carries the sound through the HDMI cable.

I have been using this headset for months on my PC only, until today.
My screen is connected to my motherboard with a HDMI cable, it was not carrying audio before today I think.
My headset is hooked to my motherboard too by USB.
It was working fine for months this way.

Today I played on my PS3 and I tried to use my headset on it.
But I have only 1 HDMI cable at home.

Today I played on the PS3 and I hooked my headset to it.
This headset is said to be working for PC/PS3/PS4, so I was not expecting anything bad, it is made for it after all.
I hooked my headset to my PS3 by Optical, only way.
I could hear the sounds from the playstation menus and in-game sounds in the headset, all was perfect.
But I was playing by using the original garbage composite cables from the PS3 box, so the visual quality was terrible.
I thought I could use the HDMI cable from my pc so I unplugged my PC screen for the first time.

So what went wrong:
I unplugged the HDMI cable from my pc.
I plugged it between my HDTV and PS3.
I plugged my headset by Optical between my headset box and my PS3.
As soon as I launched the PS3 it detected the HDMI and asked me if I wanted the audio to be carried by the HDMI, I pressed "Yes".
I found out my headset was not carrying the sounds from the PS3 anymore, I realized "ah right thats because the HDMI is doing it, ok then no problem, I cant use my headset with my PS3... Sad and lie from company but I can play with the HDTV sound system"

Then, I stopped playing on the PS3, hooked again the PC monitor with my HDMI cable (which is now carrying sounds). I plugged my headset to my pc again with USB, like before. NO SOUND.

I tried every possibility to plug it with optical, reseted the profile and sources from the headset box. Nothing to do...
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
thank you for your answer, but this is the thing, I can't see my headset anymore. It is not detected in the Steelseries engine software and also it is not in the list in control panel / sound / playback.



It is as if the HDMI cable was taking priority over the USB headset ignoring it and making it impossible to be detected
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
control panel > devices and printers > add device > should automatically search for devices plugged in

make sure the headset is plugged in before you start

you could also try reversing what you did to break it:
plug ps3 in via shtty cables,and plug headset in, so ps3 pushes sound through headset
then plu ps3 in via hdmi and select 'no do not use this device for sound too' - making the ps3 use your headset for sound with hdmi.
then try using your headset?

or plug your pc into monitor with dp/vga so sound cannot be carried to monitor, and plug in usb headset.
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
You will not believe me...
I plugged my PS3 with the 3 composite cables (Red, White, Yellow) on the back of my TV.
I started the PS3, I chose as source AV with my TV remote controler.

NO SIGNAL.

I can't use my PS3 anymore with the original composite cable, only with the HDMI cable from my pc...

I used my PS3 with those cables on that exact TV for 3 years, the day I try with a HDMI cable it is not working anymore with the original cable...
I don't find any logic in all this...
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
While turning on your PS3, hold the power button down for about 5 seconds until you hear two beeps. This should reset your video settings to basic and allow you to configure the output (composite/component/HDMI) choice
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
Ok that was it indeed, I had to hold it for 5sec, I managed to get an image again with the composite cables, I even used the headset via Optical on the PS3 like earlier this afternoon and I had sound from it.
I unplugged everything, tried the headset on the PC (still hooked via HDMI), no sound.

I unplugged the HDMI cable and the headset from the PC, plugged those on the PS3, I got the image and sound also from the headset and I had that choice again:



So I chose "No" this time, then the TV screen went black, figured it would be normal.
So I unplugged all, plugged the HDMI cable and headset back on the PC.

No sound...
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
My monitor is Samsung S24C350H, it doesnt give sound, just the image.
I should add that my only device and source for sound is the headset.
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
does your headset have a control box? if it does, there is a pc setting menu in there to select.

else un-install steelseries software, and plug in headset. then re-install steelseries
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
Yes it comes with a control box


It is set as PC, I created a PS3 source with optical, the PC is with USB in and out.
I even reseted everything see if it changed anything, I created the PC source again, but it didn't solve the issue.

I uninstalled Steelseries Engine, now downloading it for another 17min, I will try as soon as it is downloaded, but I have very little hope.

I think it is due to a priority given to something via HDMI over the USB headset.
My last solution being buying another HDMI cable and use it for the PC, and never hook it to the PS3. And use the one I have today for the PS3 only.
But I am not confident it will solve the issue.
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
:( im sorry i cannot be of any more help, and i gotta go bed due to work early tomoro morning >< i hope re-installing helps.

complete power down of pc before re-install. not a fast shutdown.
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
Well, I just reinstalled the software after a complete shutdown with my headset connected via USB.
It doesn't display my headset in the software, only the keyboard (same brand, see picture a few posts above).

So the HDMI cable is taking priority over the USB I think.
I don't know how to solve this...
But I appreciate your help SoggyTissue, thank you.
 

SoggyTissue

Prominent
Jun 27, 2017
158
0
710
45
you could always try dp if your gpu and monitor support it? or vga port? you can also get port converters dp/vga to hdmi etc. probably by tricking the computer into believing youre not using hdmi (because youre using a converter at the pc end) it will switch off the hdmi sound priority.

i did read somewhere that your box may have a firmware bug/issue and it might need resetting.
 

Soft paw

Estimable
Dec 22, 2015
10
0
4,560
0
So, a bit of updates.

I purchased a HDMI cable.

I uninstalled some devices from Device Manager, under Human Interface and USB (not all), I didnt have mouse anymore, so I stopped at this point and decided to format instead.

I formatted (removed all, reinstalled windows on partition)

I downloaded the USB and Audio drivers for my motherboard on the official website of Asus.

I opened a ticket on the website of Steelseries, under my account.
The man advised me to reset and pair-ed again to my pc after that, with the small box.

Still no sound after each of these.
I didnt buy a VGA HDMI converter because it is 30 euros.
 
Thread starter Similar threads Forum Replies Date
swat14888 Audio 2
S Audio 5
Z Audio 2
I Audio 6
D Audio 1
O Audio 3
D Audio 1
Y Audio 1
M Audio 1
PetarV Audio 1
S Audio 7
N Audio 3
Lekingmoonya Audio 9
T Audio 2
A Audio 2
A Audio 9
W Audio 3
M Audio 6
A Audio 1
T Audio 1

ASK THE COMMUNITY