How do i charge tablet when charger input broken

Thread starter Similar threads Forum Replies Date
P Android Tablets 9
Tech125 Android Tablets 8
snailmail26 Android Tablets 3
I Android Tablets 2
V Android Tablets 1
Karleen60 Android Tablets 1
P Android Tablets 3
D Android Tablets 1
H Android Tablets 1
P Android Tablets 1
H Android Tablets 1
C Android Tablets 1
R Android Tablets 2
D Android Tablets 1
M Android Tablets 2
S Android Tablets 1
T Android Tablets 1
B Android Tablets 1
A Android Tablets 3
W Android Tablets 1
Similar threads
Question Help with lenova tablet it will not charge
Question Tablet refuses to charge or turn on whatsoever.
Question Looking for an android tablet with a removable battery that can be charged externally
Solved! Samsung Galaxy Tab 2 (GT-P7500) won't turn on or charge
Solved! Huawei tablet won't charge unless I plug charger in and restart
Solved! irulu x7 won't turn on
Auto on when charging Lenovo tablet
I have a rca 10 Viking pro 2 in1 tablet. I replaced with a brand new battery. It still won't turn on. Nothing but blue charge
Solved! My charger port is broke,is there away to charge it with a usb port or a hdmi cord
my tablet do not show it charging after connected to charger
Solved! Although my charger is plugged into my tablet all the way, it won't charge at all.
is there anyway to charge a tablet thay doesn't charge off a wall charger
I'm in France and my Samsung Galaxy tablet wont charge. I've tried using a French charger (so no voltage adapter) and also tri
I have an Samsung tablet and I haven't charged it for over a year. I just plugged into charger but screen is black. No signs o
RCA Viking Pro tablet one year old won't hold a charge but I can use it as long as it's plugged into a charger into a wall
My Samsung tablet works on charging but after removing charger it gets switch off again and again ?
Recognizes charger but not charging
My rca tablet want charge. I've bought brand new chargers. An all it will show is like a yield sign with a battery an a explor
My tablets charger port won't take a charge?
Tablet won't boot after discharging completely