is my graphics card broken?

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0
ive been doing a lot of research on my lenovo y510p laptop to try and figure out if im supposed to be able to run fallout 4 well. and i finally came across a video showing how it should run with shadow play running as well and he was getting around 30-40 fps on high settings. he had capped his frame rate using some program so that the 10-20 extra frames could be used by shadow play.. if you need the link to the video just ask. but anyways the point is i cant run fallout 4. i thought i would be able to because i have better than the system requirements for it but i had to install so many optimization mods just to get it to run well on the lowest settings possible and even then i still lag in certain areas.even on the lowest resolution. trying to play on high like in the video results in 10-20 fps and tons of latency/lag. here are my specs. i have 2 gpu's one is Intel(R) HD Graphics 4600 the other is my one i use for all my games NVIDIA GeForce GT 755M. windows 10, 12gb of upgraded ram (previous was 8gb until i put in a 4gb ramaxel branded ddr3 204 pin with my Samsung 8gb ddr3 204pin) i have 8 Intel(R) Core(TM) i7-4700MQ CPU @ 2.40GHz cores. if you need to know anything else about my specs just let me know. i play all games with my battery out and only running on charger cable power to reduce heat. my laptop is on a crappy cooler which is on a hard surface (trying to get the money to upgrade that)
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0


how would i do that? i have a disc drive in my ultrabay. i got my graphics card and specs from device manager under display driver and copied them word for word.
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2


So there is no second 755m showing up in the device manager? right- click on your desktop and open the nvidia control panel. Under 3d settings enable sli technology.
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0


no there isnt. i can possibly figure out how to send you a screenshot through this website if youd like. and there isnt an option for enabling sli technology.
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2
Try deleting your drivers by using something like driver sweeper, and install the newest ones from the nvidia home page. If that doesn't help, you might have a hardware issue.
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0


ive taken it to best buy before and they said they had updated and renewed all my drivers and software so that everything on my pc was up to date. could it be that dust is making it perform poorly? so great now ive gotta find another nvidia 755m. and every where ive looked so far the cheapest one i could find is $350. i have no idea what im going to do. do you got any tips? do you know of a repair shop besides best buy? they never fix the problems i have and we end up having to take it back after about 3 days.
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2


Nvidia releases new drivers every couple of days. I would still advise you to delete and reinstall your nvidia drivers. Normally when this issue occurs on a desktop pc it's because of a broken pcie slot. What you could do is, opening it up and see if the GPUs are removable. If they are you could try troubleshooting. If they aren't or if you are afraid to do so you might wanna take it to a laptop repair shop or something. The only other thing you could try is do doing a completely clean reinstall of your OS. Doubt that would help though. Like I said, try reinstalling the drivers. If after that the 2nd card doesn't show up and the sli option is not available in the nvidia control panel, you will probably have a hardware issue.
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0


in any case scenario can deleting and reinstalling my nvidia driver cause any issues? and how do i uninstall and reinstall?
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2


Installing Drivers won't case any issues.
to completely deinstall you drivers, use something like driver sweeper. It's not necessary to delete them before installing the new one, but do it just to be sure. Having 2 different drivers can sometimes cause issues. To download the new ones, go to the nvidia homepage. After you deinstall your drivers your resolution will be messed up until you install the new ones. That's normal don't worry about it..
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0



could you give me a link to download it? my security system (webroot) said it was a "threat"
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2


http://www.guru3d.com/files-get/display-driver-uninstaller-download,20.html
Should start the download automatically, when you reach the page.
 

EncryptedNova77

Commendable
May 10, 2016
9
0
1,510
0


i dont think i have it.... http://imgur.com/a/z3S9o
 

rhelmar1

Commendable
May 23, 2016
10
0
1,570
2


Even with the newest drivers? Well, it will probably be a hardware related issue then. You will have to let someone, who is good with hardware, take a look at it. I hope you can get this sorted out. Good luck!
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 5
M Laptop Tech Support 0
F Laptop Tech Support 1
J Laptop Tech Support 1
J Laptop Tech Support 2
A Laptop Tech Support 5
K Laptop Tech Support 1
T Laptop Tech Support 1
T Laptop Tech Support 3
J Laptop Tech Support 2
I Laptop Tech Support 4
T Laptop Tech Support 2
R Laptop Tech Support 1
X Laptop Tech Support 1
Ocelotgoesmeow Laptop Tech Support 1
A Laptop Tech Support 1
C Laptop Tech Support 7
Q Laptop Tech Support 12
K Laptop Tech Support 1
G Laptop Tech Support 6

ASK THE COMMUNITY

TRENDING THREADS