Issue with battery depending of plugged or not (black screen at startup).

Oserkos

Commendable
Aug 19, 2016
3
0
1,510
0
Hi everyone !

On a laptop (Toshiba Satellite C55, win 10), I have an issue with the battery.

Laptop shut down, when I plug the battery, the LED of battery is orange (in charge).
If I try to start the laptop, I have a black screen but (1) LED of power is white (the usual case), (2) wifi LED is not lightning and (3) the noise of the laptop is as when he starts as usual.

If I unplug the battery, the LED of battery is not lightening (because there is no battery), and if I try to start the PC, it starts normally, with white LED for power and orange LED for wifi (as usual).
If I plug the battery when the PC is started, the LED of battery is orange (in charge) but Windows says that there is not battery (in bottom right, there is the symbol of the battery with a X on it, as when there is no battery).

I tried to shut down, unplug battery and the power cord, push power button for one minute, start without battery, shut down, start with battery, but it doesn't works.

Maybe there is a conflict between the battery and the wifi card and, when battery is on, the wifi card is not recognized as well (then the LED of wifi is not lightning) and that's why I have blackscreen but laptop running... Or maybe battery is not well recognized and the BIOS is blocked trying to recognize it...

A precision is that I can't disassemble my PC (I don't have enough skill and disassemble my laptop means that I should remove the screen and keyboard, so...)

Thanks and sorry if I have bad english.

EDIT
Some new things :
- if I try to start the laptop with battery on and unplug the battery when I'm on blackscreen, the pc doesn't starts and stays at the blackscreen
- in fact, there is a little trap and I have access to some components (some pics : overview of the pc, CMOS battery, I don't know what's this and another pic)
- after trying to push power button for a minute yesterday, today the pc shut down suddenly sometimes when started (anytime : one time at the toshiba logo, one time when watching a video on youtube...).

Hope it's helping... Thanks in advance.
 

Oserkos

Commendable
Aug 19, 2016
3
0
1,510
0
No I'd prefer to see if this problem can be solved without purchasing another battery. But I understand it could bring new informations. Anyway, if a new battery solve the problem, what could be this problem (a problem of the battery itself I suppose...) ? And if a new battery don't solve the problem, what can I do ?
 

hang-the-9

Titan
Moderator


If a new battery does not help, it may be an issue withe the connector on the laptop or the motherboard power circuit. At times that can be replaced without replacing the motherboard fully.

That looks to be a fairly recent system, did you already contact Toshiba support?
 

Oserkos

Commendable
Aug 19, 2016
3
0
1,510
0
Okay thanks. Today I bring it to the reparator and when I call him, he said that it could be a battery problem. I hope it's only this...
And no the laptop is at win 10 but was at win 8 when purchased, I think the warranty is over.
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 1
R Laptop Tech Support 5
CL19 Laptop Tech Support 1
A Laptop Tech Support 3
Ineedanewusername5 Laptop Tech Support 8
K Laptop Tech Support 1
Acer aspire e 15 Laptop Tech Support 2
T Laptop Tech Support 3
ToceeDav Laptop Tech Support 3
J Laptop Tech Support 3
U Laptop Tech Support 1
Y Laptop Tech Support 3
A Laptop Tech Support 1
A Laptop Tech Support 2
D Laptop Tech Support 3
1 Laptop Tech Support 1
I Laptop Tech Support 1
L Laptop Tech Support 1
benz.media Laptop Tech Support 2
P Laptop Tech Support 21

ASK THE COMMUNITY

TRENDING THREADS