Laptop not using dedicated graphics

HeadlessHamster

Estimable
Dec 12, 2015
2
0
4,510
0
My laptop doesn't use the dedicated graphics card (gtx 1060 6gb) when only using the laptops screen. When I connect a secondary monitor, it does use the 1060. Is this normal and is there something I can do about it?
 
The vast majority of gaming laptops use Nvidia Optimus. The Intel integrated card always drives the screen. The Nvidia GPU acts as a co-processor. If you select (in the Nvidia control panel) a game to use the Nvidia GPU, it will render each frame on the GPU. When each frame is completed, the Optimus drivers will transfer the completed frame to the Intel integrated graphics, which then displays it (basically it's like vsync is always on, with the two GPUs acting like the two vsync framebuffers).

Most of these laptops also have the Intel integrated graphics drive the external display port. But a small number of them have the Nvidia GPU drive the external display. It sounds like you've got one of these models. And either you don't have the correct Optimus drivers installed, or have it set to always use Intel graphics.

Right-click your desktop. You should see Nvidia Control Panel as one of the options. That's what lets you adjust the Optimus settings, deciding which games use which GPU. If you don't have this option, try going to your laptop manufacturer's support website and downloading the GPU drivers from there instead of from Nvidia or Intel. They may be out of date, but they should work. (Windows 10 Update may also install graphics drivers which don't work, though on my laptop at least they finally fixed this problem earlier this year.)

Edit: A small number of older games (or badly-written new games) do not work with Nvidia Optimus. They were written when computers only had one graphics card. So when the game starts, it queries the hardware to figure out which GPU you have installed. It finds the Intel integrated graphics first since it always drives the screen. Then the game stops looking so it never sees the Nvidia GPU, and you're stuck using Intel graphics. Since your laptop uses the Nvidia GPU to drive the external display, if you play the game on the external display it finds the Nvidia GPU first and runs on that.
 

HeadlessHamster

Estimable
Dec 12, 2015
2
0
4,510
0


I set my preferred gpu to the Nvidia gpu, but it still doesn't work. Also tried disabling the intergrated graphics in the device manager, but that also did nothing. I will try to install the drivers from the manufaturer to see if that works.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 1
T Laptop Tech Support 14
P Laptop Tech Support 3
B Laptop Tech Support 5
Y Laptop Tech Support 3
A Laptop Tech Support 1
B Laptop Tech Support 1
M Laptop Tech Support 2
F Laptop Tech Support 8
N Laptop Tech Support 4
W Laptop Tech Support 3
R Laptop Tech Support 6
S Laptop Tech Support 5
S Laptop Tech Support 1
V Laptop Tech Support 1
M Laptop Tech Support 7
R Laptop Tech Support 4
ArReKa Laptop Tech Support 1
M Laptop Tech Support 1
H Laptop Tech Support 3

ASK THE COMMUNITY

TRENDING THREADS