Laptop powers down only during installation


Nov 22, 2011
Hello everyone

I have a Toshiba L640 M4010 AMD athalon II based laptop, with 3GG ram. I was using windows 7 from a long time and I want to reinstall the OS,

I have booted from the DVD. But during the process laptop powers down. I can hear the FAN is going crazy before it powers down. I have installed this OS over a year ago several times very smoothly.

Then I tried to install Linux. Just minutes after the Linux boots in my drive, Laptop powers down.

I thought it might be the DVD drive issue so tried to install the same from USB image. Again the same issue

I ran memtest86 from the live CD. Just after 3 minutes CPU fan was going crazy and PC powers down again.

I removed the RAM and tried installing the OS by just keeping 1 module. (assuming if the other has gone bad) same thing happened in both the cases.

Now the only thing it boots is already installed old Windows 7 from my hard drive. Which takes about 5 minutes to boot.

My last guess is the display memory has gone bad ( I am not sure). Is there any other thing I can try here?

Thanks in advance :)
check to see if there any shut down temp in the bios. they may be set to low. if not it could be that the cpu cooler or laptop full of dust or the paste has dried out or the cooler over time has come lose. if the laptop under warranty some people by the extended warranty send it in for overheating. if you have some canned air or a compressor you can try blowing the fan and dust out.