Question laptop stuck on internal speaker output

May 31, 2019
1
0
10
0
i have a msi gs65 laptop and sometimes when i plug in new audio devices i get this little pop up that asks me if i want to optimize the audio or something like that. i clicked the optimize thing, and now my laptop will only play though the speakers even if i plug in my headphones. this has happened before but the other way around, where nothing would play out of the speakers and only out of the headset. i just cant remember how to get into this meny and ive tried to search around and i just cant seem to find out how to fix it. i did manage to fix it last time but sadly i have forgotten how... hopefully if anyone has a laptop with a similar feature maybe they could help me.

the headset will work through Bluetooth btw if that helps
 
Last edited:
If your external speakers/headphones aren't working, try the following...

  1. Go to "Control Panel".
  2. Click on "Sound".
  3. Make sure you are on the "Playback" tab.
  4. Click on the device you are trying to fix.
  5. Now click the "Configure" button and follow the prompts. (Be sure you also click the "Test" button.)
  6. Once that is complete, click the "Properties" button.
  7. When you are done with your changes, in "Properties", click "Apply" and then "OK".
  8. Then click "OK", again, on the main "Sound window".

You may also want to try this...

  1. Go to "Control Panel".
  2. Click on "Sound".
  3. Make sure you are on the "Playback" tab.
  4. Click on the headphones (they must be plugged in) to highlight them. Not to open.
  5. Right click on them and choose to set them as the "Default device".
  6. The click "Apply" and "OK".
  7. Now unplug the headphones and right click on the speakers. They should show as the default.
You should no longer get sound from the speakers when headphones are connected.


NOTE: If the headphones don't show in there, right click on the white background of that window and make sure both "Show disabled devices" and "Show disconnected devices" is checked.

Should you still not see the them, right click on the "Speakers", only while the headphones/speakers are plugged in, and disable them (the speakers). This may resolve the issue. Be sure you test that the internal speakers work again, when you unplug the headphones/speakers.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 1
TheKiwi01 Laptop Tech Support 3
chippy-mx Laptop Tech Support 2
S Laptop Tech Support 1
N Laptop Tech Support 2
justin0106 Laptop Tech Support 7
E Laptop Tech Support 1
SnackinMcCracken Laptop Tech Support 1
mfenton27 Laptop Tech Support 4
M Laptop Tech Support 6
A Laptop Tech Support 3
Goran Petric Laptop Tech Support 4
G Laptop Tech Support 1
S Laptop Tech Support 1
N Laptop Tech Support 1
A Laptop Tech Support 1
T Laptop Tech Support 1
A Laptop Tech Support 1
A Laptop Tech Support 2
A Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS