Question Logitech z506 subwoofer stopped working can anyone help please?

Apr 15, 2022
1
0
10
0
Logitech Z506 suddenly stopped working can anyone help please? The speakers work fine although 2 of the outputs are no longer the best quality. The sub just stopped working one day though. I have tested the potentiometer and the resistances are as you would expect, the connections all look ok. The only thing I can think of is that the sub isn't getting signal anymore from the amp so maybe pcb failure but I can't see any issues? Is there any way to test? I don't really want to solder unless I Have to but any info would be really helpful please? I have a multi meter and have checked the YouTube video but still can't fix. Thanks
 
May 17, 2022
1
0
10
0
I have similar issue with my Z337. one fine day I realize that there are totally no sound coming out from the subwoofer. I kinda verified it by unplugging the satellite speakers and proven that there are no sounds coming from the sub. I was kinda unlucky when I send mine for warranty claim during the warranty period as the sub decided to be working again after not receiving power for a few days(during the courier period). They just snd the sub back to me and it was woking fine until the warranty period ended and now even powering it off doesn't help to restore the sound anymore.
 
Thread starter Similar threads Forum Replies Date
marz lee Audio 2
A Audio 1
F Audio 3
JonathanDQT Audio 2
B Audio 5
K Audio 2
Ausbeancounter Audio 3
K Audio 1
S Audio 2
B Audio 1
J Audio 6
M Audio 2
M Audio 3
S Audio 5
L Audio 1
R Audio 1
E Audio 1
J Audio 2
S Audio 1
W Audio 1

ASK THE COMMUNITY