MacBook Pro Batteries not installed

blacksheep0424

Estimable
Dec 2, 2015
1
0
4,510
0
OK let me start by saying I consider myself tech savvy but am now feeling defeated, so I decided to ask the masters on this site. I have a MacBook Pro that I am pretty sure has had some water damage. That being said the laptop runs great when plugged in but will not run on battery. In fact the laptop has the black x inside the battery and says no batteries installed and the adapter light is always green. When I remove the power it shuts off.

What have I tried:
1. SMC Reset
2. Tested battery in another working MacBook and it works fine
3. Tried battery from working laptop and still have the error
4. Started fresh with new recovery
5. Boot into single user mode and try /sbin/fsck –fy
a. This returns an error and says failed (I will update with error later)

The weird stuff:
I can boot into single user mode unplug power cord and it runs on battery forever. I can then reboot and the laptop will run in regular mode on battery but still shows no batteries installed.

I will be ever grateful if someone has any insight and I will try to answer any questions that you may have in order to help solve this, thank you in advance.
 
Thread starter Similar threads Forum Replies Date
K MacBooks 0
MikeT_676 MacBooks 5
R MacBooks 0
E MacBooks 4
R MacBooks 0
H MacBooks 2
I MacBooks 1
S MacBooks 0
g.syder MacBooks 2
S MacBooks 1
T MacBooks 5
M MacBooks 1
C MacBooks 9
S MacBooks 1
J MacBooks 6
M MacBooks 7
M MacBooks 2
G MacBooks 2
R MacBooks 5
rodion15 MacBooks 4

Similar threads


ASK THE COMMUNITY