Question Monitor Connection over HDMI

Jun 6, 2020
2
0
10
0
I have a weird problem when I try to connect to the monitor over HDMI.
I have bought ultra-wide monitor ( Asus xg49vq), I made the HDMI connection between monitor and Laptop and projected the laptop screen to it (by Windows P). The computer seems not to recognize the monitor and throws back to Laptop screen again.
But the weird part is when I restart the computer, startup screen appears at the monitor and seconds later it throws back again to Laptop screen.
Also when I open the BIOS screen it appears on the monitor too.

I really dont know If it is because my Laptop doesnt support the ultra-wide monitor. (If so, why it works on start up and on BIOS)
or there is software issue on my Laptop (which is I am not sure, but all the drivers are up-to-date)

Please help! I am lost finding a solution.
 
Thread starter Similar threads Forum Replies Date
K Laptop Tech Support 1
Anderdid Laptop Tech Support 13
P Laptop Tech Support 11
Mathias Aivasovsky Laptop Tech Support 1
Pte Junior Laptop Tech Support 0
Ominous Potato Laptop Tech Support 0
derbu Laptop Tech Support 0
Averyonetimeuser Laptop Tech Support 0
darren12341234 Laptop Tech Support 1
C Laptop Tech Support 2
paccjas Laptop Tech Support 1
T Laptop Tech Support 8
282aviral Laptop Tech Support 1
SnazzyS Laptop Tech Support 10
aparky42 Laptop Tech Support 1
prodbyzy Laptop Tech Support 0
Hifrotech Laptop Tech Support 0
geriuu Laptop Tech Support 3
T Laptop Tech Support 6
J Laptop Tech Support 0

ASK THE COMMUNITY

TRENDING THREADS