Discussion My phone cannot find the WIFI at my work place.

Jul 22, 2019
It used to work, I have the Network SSID saved in my phone with the access code, yet now the SSID does not even show up in the list of WIFI connections. It does show on other workers phones and they are able to connect. So the WIFI router at work is working just that my phone is not detecting it. Tried turning the phone off and back on yet still no change.
NOTE: If none of the following work to resolve the problem, and if the phone is under warranty, I would contact the manufacturer.

1. Try and restart the phone. Sometimes it is that simple.

2. Update the firmware and any apps that need updating on the phone.

3. If the problem persists, check your time and date on the phone to make sure it is correct.

4. Should none of the former work...

a. Clear out the WiFi data on the phone.
b. Reboot the modem/router.
c. Once the modem/router is fully 'up' again, reboot the phone and re-input the WiFi data.

5. Make sure you have "Data" turned off on the device when using "WiFi" (that is if you have a plan with data through your phone). If youdn't make sure it is turned off, the device can keep trying to switch to "Data" when you try and use "WiFi".

6. You said the WiFi works for others, but since it is at work it is completely possible that they made changes to the access. You can block specific devices, it also could be the type of connection. If none of the above works, then I would check with your companies tech department to make sure they didn't change something or block you.

7. Now, if you are still having the problem at this point, and you are sure it isn't the modem/router that is the problem. Then you may wish to try a "Hard Reset" of the device. However, I really suggest saving this as a last option (or last before parts repair/replacement).

NOTE: Doing this will clear 'all' the data on your phone, so it is suggested you not choose this option unless you have to, or aren't worried about losing anything on the device.

Be sure you back up any data you want to keep, to a computer or cloud account, before doing the reset.

To "Hard Reset" the phone...

1. Make sure that the phone is actually powered off.

2. Press the "Power" and the "Volume Up" buttons, together, until you see the start-up logo on the screen.

3. Once you can see the logo, release the buttons and allow the device to enter the "System Recovery Mode".

4. Next use "Volume Down" button to get to the "wipe data/factory reset" option When in recovery mode the "Volume Up" and "Volume Down" buttons are how to can navigate and highlight what option you need.

5. Once you have selected the "wipe data/factory reset", press the "Power" button to select that option.

6. On the following screen, repeatedly press the "Volume Down" button until the "Yes - delete all user data" option is what is selected.

7. Then press the "Power" button to hard reset the phone.
Jul 19, 2019
If all the stuff that @webworkings gave you doesn't work, I think you should try to manually add Wifi network.
I used to have this problem with my S8 Plus and tried to find some apps like Wifi Master Key or Wifi You on APKNite with the hope that it could find out my network at home, but it didn't.
You can follow these steps:
  1. Tap Settings
  2. Network & Internet
  3. Tap Wi-Fi
  4. Ensure that the WiFi switch (upper-right) is turned on
  5. Tap Add network
  6. From the Network SSID field, enter the appropriate network name
  7. From the Security field, tap the Dropdown menu
  8. Tap the applicable security option:
    • None - If using an Open network (None), skip to step 11
    • WEP
    • WPA/WPA2 PSK
    • 802.1x EAP
  9. If prompted, enter a User name in the Identity field
  10. Enter the password into the Password field
    • Note: To view the password as it is being entered, tap Show password
  11. Tap Advanced options and then ensure all additional settings (e.g. Proxy, IP Settings, etc.) are configured appropriately (if applicable)
  12. Tap on the arrow under Hidden network to change the selection to Yes
  13. Tap SAVE
Good luck!

MOD Note: solution plagiarize from https://help.republicwireless.com/h...dden-WiFi-Network-on-Android-8-Oreo-or-Higher
Last edited by a moderator:
Jul 22, 2019
The phone is not under warranty it is an LG Rebel Tracfone. And being that it is a Tracfone it does not come with any update apps.
"1. Try and restart the phone. Sometimes it is that simple."
Been restarted several times no help.
"b. Reboot the modem/router."
Being a WIFI from work I do not have the options to do this, and as said it is still working for other persons here at work.
"I would check with your companies tech department to make sure they didn't change something or block you."
Highly unlikely, as this is a small business with only a few employees, and I do not normally have a need to access the WIFI with my phone, It just normally used to connect automatically anytime I was in range, as does all the others that work here.

I have also tried re-adding the network manually and now shows I have the network saved twice in my saved networks, however it cannot connect to this network if it does not detect the network. and that is what the problem is, my phone does not show the Network as being available. Other companies that are located in this area are showing up as available networks, just the one here is not showing up. When I get home the Network from my home still shows up and still connects automatically.
The most logical explanation is the one that is most unlikely, as there is no reason that my phone would be blocked from the Network here at work.
Jul 22, 2019
Ok, I talked with my boss yesterday and found out what had changed with the WIFI, and had found out that they had discontinued using the 2.4 GHZ WIFI and are now using only the 5GHZ WIFI and my phone is an older phone that does not work on the 5GHZ band.