New laptop not preforming like it should

fudycuda

Distinguished
Mar 14, 2009
6
0
18,510
0
I have just recently purchased a new hp laptop with good enough hardwear that it should be running games much better than it actualy is. It doesnt seem to be performing much better than my last pc that i bought in 2005 and that one only had an ati x300 vid card and p4 3.0 where as my new laptop has an amd turion x2 ultra 64 and the ati radeon hd 3450 with 4 gigs of ram.I've run just about every available test(vista and 3rd party softwear)there is.If anyone knows any conflicts or bottlenecks or just owns one of these and has any ideas on whats going on i would greatly apreciate some help.Its an HP Pavilion dv5-1250us Entertainment Notebook PC.
-Thanks in advance-
 

frozenlead

Distinguished
What are you playing, at what resolution and settings? What's the CPU's clockspeed?

Also, it should be noted that the mobile 3450 isn't exactly a gaming card, but it should do okay on low.
 

fudycuda

Distinguished
Mar 14, 2009
6
0
18,510
0
cpu clockspeed is 2.1 x2 with 1024 x2 L2 cache and the games im playing arent even runing right on low with all the power settings set to max performance i even spent a day messing with the ati controll panel along side l4d and a few older and newer games and it was inconsistant at best but most of the time it was purly lag
 

fudycuda

Distinguished
Mar 14, 2009
6
0
18,510
0
l4d=left 4 dead and ive also tryd unreal 2 the awakening and also bioshock and the strange thing is is that even though one of those should be much easer to run(unreal)than the rest it still runs with major lag on low setting.even my last pc could run that one on full,bioshock of course i need to set on low but it was the same as unreal and same with l4d im thinking theres some sort of conflict and when i updated the driver it got worse i had to reinstall from the HP site
 

frozenlead

Distinguished
Sorry, I missed the l4d.

You're right. The fact that Unreal 2 lags tells me you've either got a major GPU malfunction (unlikely) or a major software problem. Did you uninstall the old drivers before you installed new ones?

I don't really know which ATI driver is best right now - but you might get a clue if you head to laptopvideo2go.com and find the most popular ATI driver.

Keep trying new drivers for a while. If it doesn't improve, we'll get to bigger and better things.

Also, as a precaution, record some of your temps for CPU and GPU.
 

fudycuda

Distinguished
Mar 14, 2009
6
0
18,510
0
thanks for the advice i realy apreciate it ill check out the different drivers hopefully that will help, but i still have 7 days on my 15 day garanty so maybe ill just fork over another 200$ and upgrade a bit
thanks again
 
Thread starter Similar threads Forum Replies Date
D Laptop General Discussion 2
B Laptop General Discussion 0
frylc Laptop General Discussion 4
Fazal Jarral Laptop General Discussion 1
OofusDeletus Laptop General Discussion 2
J Laptop General Discussion 4
M Laptop General Discussion 0
H Laptop General Discussion 2
Dirb Laptop General Discussion 1
lolmopbomb Laptop General Discussion 1
antonioportasdasquintas Laptop General Discussion 1
Marcus_123 Laptop General Discussion 1
D Laptop General Discussion 2
H Laptop General Discussion 2
seal2145 Laptop General Discussion 0
annelilly2819 Laptop General Discussion 1
B Laptop General Discussion 1
A Laptop General Discussion 0
Galileu9 Laptop General Discussion 0
T Laptop General Discussion 0

ASK THE COMMUNITY