NVIDIA control panel not recognizing GPU

flyingpizza

Commendable
Aug 3, 2016
2
0
1,510
0
First of all i use a desktop, secondly, when i try to open the nvidia control panel by right clicking the desktop, it says that my computer isnt using a nvidia gpu, therefore it cant open, although im using a nvidia gtx 970 and i have installed successfully the latest drivers. But instead my pc chooses to work with the intel hd graphics 530 instead of my regular GTX 970. Any solutions?
UPDATE: No need to answer the question anymore, i got my answer
 

maxwellmelon

Honorable
Oct 2, 2013
171
0
10,910
52
is your monitor plugged into the GeForce card or the motherboard? needs to be pluged into the GeForce card to work.

you might also need to disable your onboard card in the bios settings.

 

Ironsounds

Distinguished
Jul 31, 2011
512
0
19,260
92
Hello... Are you plugged into the GPU card or MB GPU outputs?

Right Click your Desktop-Screen resolution this Panel will allow you to Change Monitor and display settings and outputs, for the OS.

Another solution would be to Disable the CPU/MB GPU in the MB BIO's to "PCIe Only" (save&exit) and plug into your Video card.
 

flyingpizza

Commendable
Aug 3, 2016
2
0
1,510
0


Hello, thanks you for your help, turns out i had my monitor connected to my mobo, instead of my gpu, did connect it to my gpu and it all worked fine
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
I Laptop Tech Support 1
N Laptop Tech Support 4
C Laptop Tech Support 5
P Laptop Tech Support 1
S Laptop Tech Support 1
A Laptop Tech Support 3
M Laptop Tech Support 3
H Laptop Tech Support 1
E Laptop Tech Support 4
D Laptop Tech Support 1
F Laptop Tech Support 8
S Laptop Tech Support 3
K Laptop Tech Support 16
W Laptop Tech Support 2
N Laptop Tech Support 2
D Laptop Tech Support 1
A Laptop Tech Support 2
G Laptop Tech Support 1
F Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY

TRENDING THREADS