Question Odd keyboard issue

kielerrr

Honorable
Apr 16, 2014
2
0
10,510
0
Yesterday my laptop keyboard started behaving in a way I've never seen. All keys worked except a few that I'll map below. When I type 'a', it will echo '1a' into every windows input. if I type '1' it will echo '1a' I even tried this with booted into linux with the same behavior. I tried in a BIOS input field when typing 'a', instead of echoing '1a' it only echoed '1'.. Now, when I hold down the 'a' it will echo '1aaaaaaa' So it's picking up the 'a' but prepending it with a '1' in every case.. It does this for the other characters below..

I'm 100% sure its a hardware issue and I've stripped my laptop keyboard down to the metal. I can't find any schematics on the keyboard to see how the matrix is setup to try and see where these character pairs meet, but I would love to find out how this is happening.

No new updates, no physical damage.. Just bad keyboard output on specific chars completely out of the blue

I know I can replace it, but the problem being simple hardware, I'd love to track it down.

The main board connector fits fine, no obvious damage to the ribbon cable.. A schematic of how the key matrix is built would hep but I cant find it. It's an ASUS Vivo Flipbook if that helps..

Anyway, please let me know if you have any suggestions.. It's 100% a hardware problem so any help getting deeper into the design of the key matrix would be super helpful.. I've scoured and scoured and haven't seen any reports of this kind of behavior.. Any help is much appreciated. Also, typing right now on a USB keyboard with no issue.

Current behavior
1 = 1a
1(held) = 1aaaaaaa
a = 1a
a(held) = 1aaaaaaa
6 = 6g
6(held) = 6gggggggg
8 = 8i
8(held) = 8iiiiiiiii
i = 8i
i(held) = 8iiiiiiiii
p = p
m = mp
m(held) = pmmmmmmmmm
 
is it like this with and without the backlight of the keyboard?

did you try Ubuntu live with it?

https://forums.tomsguide.com/threads/asus-wierd-keyboard-problems-again.325807/
" search for "Filter" under settings - and the first result is "Ignore repeated key strokes using filterkeys" - select this - the first box "Turn on Filter Keys" should be unchecked "

Did you load default settings in BIOS?
Did you update the BIOS? Eventually reflashing the same version of the BIOS can help
 
Last edited:

kielerrr

Honorable
Apr 16, 2014
2
0
10,510
0
Unfortunately I tried everything..

Filter Keys = off
Booted into kali linux from usb = same behavior in linux enviroment
In the actual BIOS config, typing 'a' into a field printed out a '1' instead of the usual '1a'
Reset BIOS to defualt
Am running latest BIOS version
Uninstalled all keyboard drivers and rebooted to reinstall,

I have now actually removed the keyboard completely, separated the layers. The metal backing/the plastic insulator/the actual keyboard with the rubber buttons.. They keyboard still works with just the array of rubber buttons, but still the same problem.

I even cut the '1' key out of the matrix, severing about 4 connections it had to the keyboard.. I pressed 'a' and it still prints 'a1'

Since I can't find the schematics of this keyboard model, I dont have the patience to try and map out how the a and 1 (or the other anomalies) are connected If I were home I would have put it on my oscilloscope to see where the lines were being crossed.

I have been running it for about 3 months with no back light. Even though my keyboard has backlight controls, they didnt work so I figured my model didn't support it. When I took the case apart, I found the backlight cable simply wasn't connected.... So that was either a mistake at the factory, I unwittingly bought a floor model or something as I bought it at BestBuy. Either way, with the back light connected or not, the problem remained.

Anyway, I bought it here in Mexico and returning it to Asus especially after breaking it down to bare bones would be a fruitless effort.. Even ordering a new keyboard and having it delivered to Mexico would be $100+

Going for the external keyboard solution now and will just remain sad that I couldn't figure out the problem.. :rolleyes:

Thanks for the suggestions
 
Thread starter Similar threads Forum Replies Date
Lucaskp4 Laptop Tech Support 1
chains65212 Laptop Tech Support 3
S Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 7
Z Laptop Tech Support 3
M Laptop Tech Support 8
A Laptop Tech Support 2
G Laptop Tech Support 1
X Laptop Tech Support 1
P Laptop Tech Support 3
C Laptop Tech Support 12
D Laptop Tech Support 1
H Laptop Tech Support 2
I Laptop Tech Support 1
V Laptop Tech Support 1
F Laptop Tech Support 1
S Laptop Tech Support 1
I Laptop Tech Support 7
O Laptop Tech Support 2

ASK THE COMMUNITY