Question Samsung TV Backlight Doesn't Turn on but there is Video and Sound

RazerMoon

Commendable
Mar 25, 2017
5
0
1,520
2
Hello there, I have a Samsung TV that has stopped working recently and I was hoping I could get some help with resolving the issue. There is a short-novel worthy story about the mysteries of this tv so I’m including it before I discuss my current situation in case it gives any ideas on what could be wrong with it.

The TV stopped working a long time ago and I didn’t bother with it for about a year until I tried turning it on again and it surprisingly worked, I updated the firmware but didn’t have any use for it at the time so I put it away somewhere (It still worked after the update).However when I tried using it again after a few months it didn’t work (again) for some reason. I opened it up, reconnected all the cables and it worked again for about a day then stopped working again. I then messed around more with the wires a couple of days ago and got it to work another time for about a day until I turned it off for a couple hours, at which point it didn’t turn on again when I tried turning it on today, fiddling with the wires sadly didn’t help this time.

————————-

Model: UE32F5300AKXXU | Version No: 3

Chassis:
CY-HF320BGSV1H

Panel: BN96-28700D

Power Supply Board:
BN44-00605A

TCON Board: RUNTK 5361TP

Main Board:
BN41-01958B

————————-

Let me start simple, do I have any idea what is wrong with this TV? I have almost no idea.

However I am very positive (though I could be wrong) that it is a Power Supply Board Issue. The capacitors look fine and the rest of the board does too but

THE BACKLIGHT DOESN’T TURN ON

I even made it look important because it is. The main issue is that the backlight doesn’t turn on, the panel should be working correctly because

I DID THE FLASHLIGHT TEST AND THERE IS AN IMAGE

Also, When I disconnect the cable from the PS Board to the Main Board (TCON just connected to Main Board btw) the backlight STILL doesn’t turn like it should. This leads me to believe this is Likely NOT a TCON or Main Board Issue.

Also also, I have read a couple of posts about this issue that state that This may be a sign of Blown LED Backlight Assemblies, however I am highly doubtful of that since I have gotten this issue multiple times. If this was the issue, I should not have been able to fix it by just reconnecting wires.

My PS Board is the BN44-00605A. I checked the voltages on the CNM803 and they seem fine.

But the CNL803 is a different story and what seems to be the issue. All the pins give pretty much no voltage except for pin 12 which starts at 223V, slowly goes down to 196V and then comes back to 223V.

This is very suspicious and is where I am stuck right now, I’m not sure what could be causing this or how I can fix it. If anyone could give me advice on how to fix this I would be very grateful.Also I know I could just replace the board but I would like to fix it myself if possible.

Images: View: https://imgur.com/a/MhbaxNw
 

RazerMoon

Commendable
Mar 25, 2017
5
0
1,520
2
Good news! turns out the problem was a diode on the PS Board but it’s a very easy fix, just had to replace it and now the tv works great. Image
 
Thread starter Similar threads Forum Replies Date
arnav9821 TVs 0
C TVs 1
Nicoletrueman TVs 0
B TVs 1
T TVs 5
M TVs 1
Patrick3214 TVs 0
R TVs 1
N TVs 5
L TVs 2
solidGoldstone TVs 0
D TVs 0
A TVs 0
T TVs 0
B TVs 0
G TVs 1
M TVs 1
S TVs 1
Z TVs 0
W TVs 0

ASK THE COMMUNITY