Serious Issues Installing OS/Drivers onToshiba Satellite

Sep 15, 2017
Its a Toshiba Satelite C55-B5202 laptop. Specs:

Windows 8.1 x64
15.6" Screen
Hard Drive: 500GB Serial ATA-300 500rpm
CPU: Intel Celeron N2830 2.16 Ghz dual core
Memory: 4 GB DDR3L SDRAM 1333 Mhz
Graphics: Intel HD Graphics
Atheros Wireless Adapter

I got it refurbished 2-3 years ago from a reputable place. It originally came with windows 8.1 . I upgraded to windows 10 and that was fine for the longest time. I believe sometime after the anniversary update is when I first noticed a problem that seemed to keep coming back and worsening. Which leads to the issue I currently have.

I was playing a pc game when it froze so bad I had to shut it off using the power button. When it came back on,
It would get stuck at the windows logo screen and hang there until turned off. Long story short, no attempts to fix the issue or reinstall Windows 10 worked. So I was forced to downgrade back to windows 8.1

Everything seemed fine for a year. Then it started happening on 8.1 like it did 10 with the Windows logo screen. The little circle of dots freezing and refusing to load the login screen. Several times the issue was remedied by going to a previous restore point. I have more issues than this but I believe it was an indication of other problems which I have or maybe it has to do with the other issues.

The worst problem started 3 days ago. I took my laptop to a place with no wifi and turned wifi off. I played an offline pc game that I just installed.

I noticed my computer was being very laggy playing the game and slow in general. When I got home, I used Ccleaner. It found about 1GB of junk files which I cleaned out. No special cleaning options were checked. Just the general cleaning options. My boyfriend asked me when was the last time I defragmented the HD. I couldnt remember so I done that.

That's when I remembered wifi was off and tried to turn it back on. The whole computer completely froze. I couldn't even use ctrl + alt + delete.
I had to hold down the power button to turn it off. Same thing happened on the next 2-3 attempts. I got a bad feeling and backed up everything I wanted to keep on an external hard drive. My boyfriend then went into the device manager and uninstalled the Atheros driver so windows would reinstall it to fix the problem. It reinstalled when we later went into safe mode, but the problem worsened.

It almost go to the login screen. I could see a faint image of the lock screen and heard the startup sound start to play and get stuck. Restarting the computer didn't help.

We went into automatic repair and tried rolling back to a previous restore point. That didn't do anything so we went into safe mode and checked on the driver. It did reinstall. While rebooting the computer, my boyfriend done both check disk and system file check in the command prompt. Check disk could not be done as C: had write protection on it. SFC found corrupted files on the hard drive and repaired them. Sadly, this done nothing to remedy the problem.

So, we tried to do a fresh installation of Windows 8.1 . The critical drivers will not install properly. Bios driver gives the error information -EC ID Check Failed. The Intel Chipset SW Installation utility keeps saying the computer doesn't meet the minimum system requirements. I went to the Toshiba site and got specifically the correct drivers *for* my os and computer model. Intel Management Engine Interface driver will extract the files and I clicked yes to give it permission. It dissappeared and never done anything. Realtek LAN driver does the same thing. The Atheros WLAN driver causes a complete computer freeze up. Sometimes this will cause the login screen not to load at all after hitting the kill switch because it will lock up on the logo screen.

Thinking it could have just been bad recovery media we, tried another windows 8.1 recovery usb.(I use a program called magical jellybean key finder so I always have my windows keys saved somewhere)

Nope same problem. We tried windows 10 again with the very same issue as over a year ago. It never makes it to the login screen freezing at the windows logo screen. As a last ditch effort we tried installing Windows 7 same thing.

We are at a dead end and don't know why this is happening and have tried googling as well as exhausting every possible solution we could think of. I apologize for such a long post. Just trying to be as clear and concise about the problems as well as solutions we tried. Thank you for your time and assistance in advance. We are very grateful for any help or ideas.

Sep 15, 2017
Oh on a side note, When we tried installing Windows 7, we did turn off windows 8 settings in bios first disabling secure boot and changing from UEFI to CSM. I really hope this can be fixed because I love gaming on Windows. I dislike gaming on Linux and would only install it as a final resort.