Question Sony Firmware update after board replacement

HazMatt

Distinguished
Oct 29, 2008
3
0
18,510
0
I have a Sony KDL-70W850B TV that had issue with TV not turning on then off with blinking red light. I diagnosed that it could be the t-con board and replaced it. When I turn TV back on, after tcon board replacement, it now blinks Amber and Green which I know means it needs a firmware update. Make sense being that I changed out the t-con board. The problem is there is no display and I don't know how to do the update. I have a USB drive with the update in it plugged into the TV as well as it being hooked up to the Internet. I have waited 20 minutes plus and still blinking Amber and green. Have tried starting over a few times. Have tried holding the arrow up button, starting the TV while holding that button and then pressing the power button to no avail. I believe I fixed the problem I just need to do the update. Please help! Thanks in advance.
 

HazMatt

Distinguished
Oct 29, 2008
3
0
18,510
0
stick with 1 thread
I have a Sony KDL-70W850B TV that had issue with TV not turning on then off with blinking red light. I diagnosed that it could be the t-con board and replaced it. When I turn TV back on, after tcon board replacement, it now blinks Amber and Green which I know means it needs a firmware update. Make sense being that I changed out the t-con board. The problem is there is no display and I don't know how to do the update. I have a USB drive with the update in it plugged into the TV as well as it being hooked up to the Internet. I have waited 20 minutes plus and still blinking Amber and green. Have tried starting over a few times. Have tried holding the arrow up button, starting the TV while holding that button and then pressing the power button to no avail. I believe I fixed the problem I just need to do the update. Please help! Thanks in advance.
 

HazMatt

Distinguished
Oct 29, 2008
3
0
18,510
0
I have a Sony KDL-70W850B TV that had issue with TV not turning on then off with blinking red light. I diagnosed that it could be the t-con board and replaced it. When I turn TV back on, after tcon board replacement, it now blinks Amber and Green which I know means it needs a firmware update. Make sense being that I changed out the t-con board. The problem is there is no display and I don't know how to do the update. I have a USB drive with the update in it plugged into the TV as well as it being hooked up to the Internet. I have waited 20 minutes plus and still blinking Amber and green. Have tried starting over a few times. Have tried holding the arrow up button, starting the TV while holding that button and then pressing the power button to no avail. I believe I fixed the problem I just need to do the update. Please help! Thanks in advance.
I had a bad flash drive which is why I couldn't update. Finally did the update and now three-quarters of the screen is black and can't be seen. Only the upper left is illuminated. Put the old board back in updated the firmware again and Screen came up beautiful fully lit and then shut down back to the full blinking lights. I think they sent me the wrong board.
 
Thread starter Similar threads Forum Replies Date
S Streaming Video & TVs 0
S Streaming Video & TVs 0
S Streaming Video & TVs 0
S Streaming Video & TVs 0
S Streaming Video & TVs 0
S Streaming Video & TVs 0
B Streaming Video & TVs 1
A Streaming Video & TVs 1
A Streaming Video & TVs 2
G Streaming Video & TVs 0
T Streaming Video & TVs 2
Z Streaming Video & TVs 4
lbenally Streaming Video & TVs 2
G Streaming Video & TVs 6
exfileme Streaming Video & TVs 11
Marcus Yam Streaming Video & TVs 105
JMcEntegart Streaming Video & TVs 44
exfileme Streaming Video & TVs 19
exfileme Streaming Video & TVs 36
JMcEntegart Streaming Video & TVs 19

Similar threads


ASK THE COMMUNITY

TRENDING THREADS