Synaptic Touchpad Refuses To Work

G

Guest

Guest
I realize this is evidently a common issue, since I received countless search results of other forums where people are complaining about precisely the same problem. The reason I'm even posting this at all is after looking at seven different forums in search of a solution, I found nothing.

I'm sorry I can't be more clear, as I have no clue what is causing this. I just know that as early as six hours ago, the touchpad was working, and now, it's not. Unfortunately, I suspect other problems I had (which I will get into in a second) with the touchpad are related to the issues I've had so far. So far, I've reinstalled the drivers for my touchpad twice, once after rolling back to an earlier version, another after completely uninstalling the driver and reinstalling it. I tried to install an earlier version of the drivers, but the installer seems to think that even the rolled back version is newer than the version being installed (despite the fact that it rolled back to version 10, and version 17 was what the installer was supposed to install).

A few days ago, I had a similar problem, except that the Device manager didn't even detect the touchpad. search results for the problem told me to do a System Restore, which I believe may have contributed to what's going on, because I thought the laptop was stuck in an infinite loop of BSoD after the restoration, but it suddenly started working on a fluke. I didn't think anything of it until now. I would try that again, but I fear this thing would Permanently be stuck in a loop of BSoD.

Any help towards resolving this would be appreciated. I have a feeling there may be information missing, but am not sure what exactly would be needed to resolve this, because my expertise is more with desktops than laptops. Regardless, I'll provide any other information needed to the best of my knowledge.
 
Hi,

It seems like you've pretty much done all the possible troubleshooting steps that should have resolved the issue.
- First was uninstalling/reinstalling the driver.
- Next is to perform System Restore.
- Last option would be to reinstall Windows itself.
- And if reinstalling Windows will still not solve the issue that could mean that the Touchpad itself it already acting up and replacing it would be the solution.
 
Thread starter Similar threads Forum Replies Date
E Laptop Tech Support 5
T Laptop Tech Support 5
M Laptop Tech Support 5
A Laptop Tech Support 1
J Laptop Tech Support 7
deepakhkadam Laptop Tech Support 1
C Laptop Tech Support 1
F Laptop Tech Support 3
Z Laptop Tech Support 1
raptormoonx Laptop Tech Support 5
C Laptop Tech Support 2
K Laptop Tech Support 1
S Laptop Tech Support 2
S Laptop Tech Support 1
S Laptop Tech Support 2
M Laptop Tech Support 5
T Laptop Tech Support 2
T Laptop Tech Support 2
D Laptop Tech Support 2
E Laptop Tech Support 2

ASK THE COMMUNITY