Toshiba C55-A Brand New Battery Stops Charging at 75%

jc1991

Estimable
May 3, 2015
1
0
4,510
0
Ok, so I have a Toshiba C55-A and the old battery was giving me problems with not charging and going from 50% to 0% in a matter of like 10 minutes. I got a new battery and it will NOT charge past 75%. I have changed the settings in the Power Options, and even tried that remove the battery, hold down the power button, then put it back together thing. I have just tried uninstalling that Microsoft PCI thing then resinstalling it, but no luck. This is a brand new battery so I am super confused on what's going on. I know the charger is good because I am able to use the computer with the battery out and just running off the charger.

Any ideas?

Also, it does say Plugged In Charging and if I unplug the charger than plug it back in, it charges for like 5 seconds then stops.
 

popatim

Splendid
Moderator
I've had this problem with cheap knockoff batteries.

If this is a real Toshiba battery there may be a way to recalibrate the meter. While its best to ask Toshiba Support directly the process is usually to charge the battery overnight then use the laptop on battery power until it turns off Turn it on again and enter the bios until it dies to make sure its drained. Then charge it overnight again. a couple of repeated full charge - discharge cycles is usually enough.
 
Thread starter Similar threads Forum Replies Date
lexahrro Laptop Tech Support 1
H Laptop Tech Support 1
H Laptop Tech Support 5
P Laptop Tech Support 3
B Laptop Tech Support 0
Wedel25 Laptop Tech Support 0
L Laptop Tech Support 1
D Laptop Tech Support 3
G Laptop Tech Support 4
P Laptop Tech Support 4
S Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1
K Laptop Tech Support 1
K Laptop Tech Support 1
A Laptop Tech Support 5
V Laptop Tech Support 9
F Laptop Tech Support 4
S Laptop Tech Support 3
G Laptop Tech Support 4

ASK THE COMMUNITY