Question Using 3.5mm jack headset on PC

Camaro

Distinguished
Aug 23, 2002
3
0
18,510
0
Hi all
Even though I build my own systems, one area I am not well versed in is audio. I have a Win 10 PC with a Sound Blaster XFI sound card. I was using Hyperx Cloud 2 headphones using usb. . .no problem. I replaced them with Hyperx Alphas and the issue is they have dual 3.5mm jacks vs usb. I’m not exactly sure how to use them on my system. Here are my questions since there is a single headphone jack on my speaker controlers, mic and headphone jacks on the front panel, on the back panel and on the sound card. I'm not sure what to do.

-Do I use the ports on the front of the case using onboard audio? Its Realtek ALC1150 with two options you can select from.

-Wouldn’t it be better to use the sound card which would have better sound. . .the issue is I can’t find drivers for that card anymore. Its not even showing on my system.

-I bought a Raccat Juke (https://en.roccat.org/Headsets/Juke) for $10 which allows you to plug the 3.5mm jacks into a USB dongle. My concern is that the sound would be better going directly into the sound card.

I did searches and I’m having a hard time figuring this out. Any help would be great.
Thanks!
 

Camaro

Distinguished
Aug 23, 2002
3
0
18,510
0
I enabled it but each setting has a red arrow on it (see pic) and won't let me set to default. I also cannot seem to update my SB card drivers. While it shows in device manager, when I go to install new drivers, it says it does not exist.
 

Camaro

Distinguished
Aug 23, 2002
3
0
18,510
0
If you have a SB card in the system but your front jacks are Realtek, you need to move the internal audio connection from the case to the sound card.

Drivers for the SB card are here https://support.creative.com/Products/ProductDetails.aspx?catID=1&CatName=sound+blaster&subCatID=208&subCatName=X-Fi&prodID=14065&prodName=X-Fi+Platinu
Thanks for the reply. I will swap the front panel connector to the sound card. When I go to update the drivers, it says no device available and will not install. So weird. The card is showing on device manager. Any suggestions?
Thanks again!
 
Thread starter Similar threads Forum Replies Date
F Audio 0
B Audio 0
A Audio 0
G Audio 1
MattC231 Audio 0
EnDy_S Audio 0
T Audio 0
Sniipe Audio 0
Captain Kino Audio 0
maveick Audio 4
E Audio 4
S Audio 3
M Audio 1
L Audio 0
Spark3 Audio 1
J Audio 2
A Audio 1
G Audio 1
M Audio 0
M Audio 0

ASK THE COMMUNITY

TRENDING THREADS