Windows 10 laptop not connecting to internet

Nov 26, 2018
1
0
10
0
My laptop was fully functioning a few days ago at my parents’ place. Today I tried connect it to wifi in my flat. It says that it’s connected (and I’ve tried this with both wifi and an ethernet cable) but it won’t load anything on the internet. I don’t get the pop-up saying there’s no connection or anything, it just keeps loading until i close the window. Wifi works just fine on my phone. I even tried opening a mobile hotspot on the laptop via wifi and connecting to the hotspot with my phone. The phone still loads everything, while the laptop won’t. Troubleshooting doesn’t come up with anything, either. Help, anyone?
 
Try this....

1. Go to "Control Panel".

2. Next go to "Network and Internet" and then "Network and Sharing".

3. Now click on "Manage Wireless Networks".

4. On this screen, remove all wireless connections by "right clicking" on it and select "Remove network" from the drop down menu.

5. After doing this, close the open windows and reboot the computer.

6. Once the computer is fully reloaded, scan for the "WiFi networks".

7. Click on the available network that you want to access and select "connect".

8. It takes a moment, but then you will be asked to give a password for your WiFi connection. Type in the password and click the "connect" button.

It should now be connected.

NOTE: If this doesn't work, you may want to reset your modem/router, and then once it is fully loaded again, repeat the above steps.

If this doesn't work, test seeing if your laptop will connect via Ethernet. If so, then your WiFi card may be going. You can either look to replace it/have it replaced, or get an external (plugs in via USB) WiFi card.


Another way to try it is to...

1. Go to "Settings".
2. Click on "Network & Security" and then click on "WiFi".
3. Now click "Manage known networks".
4. Select the WiFi connection you want to remove.
5. Click the "Forget" button.
6. After doing this, close the open windows and reboot the computer.
7. Once the computer is fully reloaded again go to "Settings".
8. Click on "Network & Security" and then click on "WiFi".
9. Now click "Manage known networks".
10. Click "Add a new network" and enter the network name.
11. Using the drop-down menu, select the "network security type".
12. Check the "Connect automatically" option.
13. Now check the "Connect even if the network is not broadcasting" option and click "Save".

Once you have completed these steps, whenever the device is within range of that particular network, it should automatically connect to it.


Also, you might want to check that both your modem/router doesn't have a limitation on how many devices can be connected at once (they do have that option in most cases) and also your ISP. Some of them limit the number of devices.
 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
TripleDigitRide Laptop Tech Support 3
D Laptop Tech Support 1
R Laptop Tech Support 1
S Laptop Tech Support 1
M Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 1
S Laptop Tech Support 2
L Laptop Tech Support 7
W Laptop Tech Support 1
V Laptop Tech Support 3
D Laptop Tech Support 2
B Laptop Tech Support 1
N Laptop Tech Support 7
J Laptop Tech Support 2
R Laptop Tech Support 3
P Laptop Tech Support 3
G Laptop Tech Support 2
F Laptop Tech Support 1

Similar threads


ASK THE COMMUNITY

TRENDING THREADS