Solved! X200 Lenovo: Plugged in, not charging

Aether_1

Estimable
Aug 19, 2015
2
0
4,510
0
I came across this scenario (and other two consequences) in which my X200 Lenovo ThinkPad Laptop is unable to charge even though it is plugged in and the orange LED light is blinking. When I start up and looked at the battery state, it says "plugged in, not charging".

So I went ahead and tried to fix the problem. I tried power draining by disconnecting the battery, holding the power button for 30 seconds, then put it back in and start up. I tried to uninstall the two driver lists in Device Manager and took the battery in then out. Both of these didn't fix it.

My asking, do I need to replace the battery or something? It looks fine and in a good condition from the outside.
(PS: I can't boot my laptop without the battery even though the power adapter is in for some reason, it couldn't boot from any device when I tried to start it without the battery.)

Any ideas would be greatly appreciated
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 1
L Laptop Tech Support 8
F Laptop Tech Support 5
E Laptop Tech Support 1
Z Laptop Tech Support 2
I Laptop Tech Support 1
T Laptop Tech Support 3
S Laptop Tech Support 1
D Laptop Tech Support 1
W Laptop Tech Support 1
P Laptop Tech Support 5
C Laptop Tech Support 1
M Laptop Tech Support 5
S Laptop Tech Support 3
S Laptop Tech Support 2
T Laptop Tech Support 26
G Laptop Tech Support 7
D Laptop Tech Support 1
A Laptop Tech Support 2
M Laptop Tech Support 2

ASK THE COMMUNITY