Acer aspire 6935G; Doesnt boot, doesnt show bios.


Aug 6, 2009
edit: I apoligise if something I've wrote here isnt right within its actual terms (such as "doesnt show bios") as I realy dont know much about the thigns generaly involved in whats going on here.

I also apoligise for lack of spelling / grammar.

edit2: Apparantly what I was looking to say was it does not bring a splash screen up or do post bios checks meaning I cant change settings / launch from disc etc, if I leave a bootable (my xp disc) disc in the drive everything is the same other than the fact you hear the dvd begin to do some rotations.

I got this laptop a few days ago, I currently have 7 and XP installed on it and kind of have vista...(read further down).
My 7 seemed to break today after playing around with a program called powerstrip trying to get my external monitor to show the right resolution (I've realised now the cable vga was broke, but meh) but this is not the full problem, after windows 7 failed to boot I tried to boot xp after turning it off during the windows 7 splash screen and now im stuck with a dash when I turn the laptop on (I dont know if its actully related to something I've done or not).

If I turn the laptop on a flashing dash comes on in the top right, it then stops flashing and turns into a none flashing dash further up the screen and just locks here and I cant do anything at all other than trying to restart it. When I had this problem previously (at least I think this problem) on my desktop it usualy turned out to be something usb related but I have everything unplugged (all though the bluetooth adapter light is on when it is doing this) so I realy dont know what to do.

I feel like a pillock with this been my first post but hopefully there isnt something I havent seen telling me how to solve this problem.
Cheers, Jim.

...The "kind of installed vista"
Basicly the first time I turned the laptop I did not realise the OS comes preinstalled but compressed and as it was installing the laptop may have ran out of battery power due to my own fault, this caused a broken vista install.
I then installed XP over the top and figured it was gone but apparantly when I installed 7 (before this problem occured) the boot menu shows: "Vista" "Older operating systems <xp ofc>" and "Windows 7"

Thanks in advance


The easiest way to remedy this situation would be to just wipe out the drive completely before you install windows. Do you have the W7 disc? If so, do a custom install and format the drive completely.


Aug 6, 2009
I've formated the HDD in my main computer to totaly nothing and still cant get anything out of it, tried the ram in different places etcetc went to reset the CMOS battery but it appears to of been burried right under some casing I'd have to take the whole thing apart for and I'm probably just going to warranty it : \...cant even find the Jumper to reset it
Thread starter Similar threads Forum Replies Date
M Laptop General Discussion 0
evilhny Laptop General Discussion 1
F Laptop General Discussion 1
SadieGirl Laptop General Discussion 0
Lle0623 Laptop General Discussion 8
Mr.Unknown Laptop General Discussion 1
B Laptop General Discussion 1
T Laptop General Discussion 2
L Laptop General Discussion 1
ndo Laptop General Discussion 1
J Laptop General Discussion 3
I Laptop General Discussion 3
P Laptop General Discussion 4
M Laptop General Discussion 2
B Laptop General Discussion 1
J Laptop General Discussion 7
R Laptop General Discussion 1
A Laptop General Discussion 3
N Laptop General Discussion 1
M Laptop General Discussion 1