Solved! Acer Nitro 5 GPU issue. Pls help me.

Status
Not open for further replies.
Apr 8, 2021
1
0
10
0
I have Acer Nitro 5 AN515-43. CPU: Ryzen 5 3550H, GPU: GTX 1650. I have 2 GPUs in my laptop, Vega 8 and Gtx 1650 but my laptop is only using Vega 8 + Gtx 1650 and also vega 8 is processing much more than Gtx 1650 causing low fps and stuttering. I did everything, I selected Gtx 1650 in 3d settings and in PhysX but it still no use. I also selected the games and put them on high performance in settings. Still no use. I disabled my iGPU but it changes to Microsoft Basic Display Adapter. Please Help Me.

Thanks in Advance.
 
May 16, 2021
1
0
20
1
I have Acer Nitro 5 AN515-43. CPU: Ryzen 5 3550H, GPU: GTX 1650. I have 2 GPUs in my laptop, Vega 8 and Gtx 1650 but my laptop is only using Vega 8 + Gtx 1650 and also vega 8 is processing much more than Gtx 1650 causing low fps and stuttering. I did everything, I selected Gtx 1650 in 3d settings and in PhysX but it still no use. I also selected the games and put them on high performance in settings. Still no use. I disabled my iGPU but it changes to Microsoft Basic Display Adapter. Please Help Me.

Thanks in Advance.
Hello, are you still facing the problem?
If yes, try this.
Settings>System>Display>Graphics settings>Browse and add the games/apps which you want to select the GPU for and you should have the option to select the GPU.
With the later versions of Windows, selection of GPU doesn't work in Nvidia control panel anymore.
 
Last edited:
May 16, 2021
1
0
20
1
I have Acer Nitro 5 AN515-43. CPU: Ryzen 5 3550H, GPU: GTX 1650. I have 2 GPUs in my laptop, Vega 8 and Gtx 1650 but my laptop is only using Vega 8 + Gtx 1650 and also vega 8 is processing much more than Gtx 1650 causing low fps and stuttering. I did everything, I selected Gtx 1650 in 3d settings and in PhysX but it still no use. I also selected the games and put them on high performance in settings. Still no use. I disabled my iGPU but it changes to Microsoft Basic Display Adapter. Please Help Me.

Thanks in Advance.
Hello, are you still facing the problem?
If yes, try this.
Settings>System>Display>Graphics settings>Browse and add the games/apps which you want to select the GPU for and you should have the option to select the GPU.
With the later versions of Windows, selection of GPU doesn't work in Nvidia control panel anymore.
 
Last edited:
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
GadgetTechMan Laptop Tech Support 0
J Laptop Tech Support 5
Jukeman_IronWulf Laptop Tech Support 1
T Laptop Tech Support 0
S Laptop Tech Support 4
A Laptop Tech Support 2
Oshadowassassin Laptop Tech Support 0
TaranWolf Laptop Tech Support 1
S Laptop Tech Support 5
thekbw Laptop Tech Support 2
Ely10484 Laptop Tech Support 0
Shrey30 Laptop Tech Support 0
Scloopz Laptop Tech Support 5
Kaiserken Laptop Tech Support 1
E Laptop Tech Support 1
xdoji Laptop Tech Support 0
I Laptop Tech Support 4
D Laptop Tech Support 1
S Laptop Tech Support 0
A Laptop Tech Support 3

ASK THE COMMUNITY