Question Acer Swift 1 (SF113) stuck on Acer Logo.

Nov 29, 2021
2
0
10
0
Hi all, I have an Acer Swift 1 (SF113-31-P20U) laptop which is stuck on the Acer Logo. After a windows update it got stuck in a boot loop and I was able to get to the blue recovery menu and start a factory reset. This is when the real problem happened. It looked like it was going to restart in the middle of the reset but it just got to the Acer logo and wouldn't go any further.

I now have a brick that lights up and goes to an Acer logo but it does nothing else.
I have tried:
  1. The battery reset hole, 25 seconds and 2/3 minutes, it just goes straight back to the Acer logo.
  2. Leaving the battery out overnight, Acer logo
  3. Leaving switched ON for 24 hours goes nowhere.
  4. No BIOS menu, no amount of hammering/holding F2, Esc, ALT+F10 after/while turning on can get me ANY menus. (no BIOS, no Acer eRecovery, nothing)
  5. Won't boot from USB stick or USB DVD, the lights on the peripheral just flash and then do nothing.
  6. Doesn't show on my router so I can't even remote install over the network.
It reacts to pressing the power button by coming on, and holding the power button switches it off after 5 or 6 seconds. The power light is a constant blue when plugged in, and the power light goes blue when turned on but otherwise zero, zilch, nothin' nada.

This model has soldered RAM and soldered flash storage so there is nothing that can be removed, apart from the battery & BIOS battery (which I also tried leaving unplugged for 24hrs).

Does anyone have ANY ideas at all as to what I can do with this machine, other that throw it under a bus? Any advice is appreciated! Cheers, J
 

AlHuneke

Commendable
Jul 7, 2020
848
102
1,490
77
You have done a good job of trying things. The fact that it won't even enter the BIOS tells me it might have a serious problem with the hardware. However, unless you know for sure the procedure to enter the BIOS, I would research the exact key needed to enter the BIOS. If you can in fact get there, you may find the boot sequence is not set up to try the to boot from USB (unless you have booted that way in the past. If you can get it to boot from USB, you can try to reinstall Windows that way. Let me know if you don;t know how to do that.
 
Nov 29, 2021
2
0
10
0
Thanks for replying AlHuneke. I know enough about computers to be 'dangerous' but I'm by no means an expert.
For this model it's supposed to be F2 to enter the BIOS . On some laptops mashing ALT+F10 at the machine logo can get you into the Windows RE but neither of these key combos work as far as I can tell. Holding F2 while switching on, pressing F2 at the logo, hammering F2 repeatedly from the second you switch it on, nothing gets me a BIOS screen. Even tried a USB keyboard in case the laptop 1 had failed somehow but nothing.
The only reason I can't accept this as a hardware fault is that I was able to get to the Windows RE and start the Reset minutes before. And then as soon as it tried to restart during the reset it got frozen at the Acer logo and has been stuck there since. I would have just reinstalled via crossover ethernet cable but this model doesn't have an ethernet port on it. There has to be something, ANYTHING that will get me a recovery/BIOS screen. It's not impossible that something failed during the reset and that's why it's broken but that would just be highly coincidental.

Any ideas people? Any thoughts are appreciated! J
 
Thread starter Similar threads Forum Replies Date
R Laptop General Discussion 1
Joemap Laptop General Discussion 0
zeezeear Laptop General Discussion 5
dsouza_alroy Laptop General Discussion 0
B Laptop General Discussion 1
S Laptop General Discussion 1
E Laptop General Discussion 1
D Laptop General Discussion 1
B Laptop General Discussion 2
A Laptop General Discussion 1
op24ti12mus94 Laptop General Discussion 3
X Laptop General Discussion 3
G Laptop General Discussion 2
D Laptop General Discussion 1
B Laptop General Discussion 2
V Laptop General Discussion 1
S Laptop General Discussion 2
I Laptop General Discussion 1
A Laptop General Discussion 7
teflonfrog Laptop General Discussion 1

ASK THE COMMUNITY