An operating system wasn't found after installing Windows 10 to M.2 SSD

Aster321

Estimable
Jan 16, 2015
9
0
4,510
0
Morning everyone!

I recently bought a new laptop (MSI GL62M 7REX) and a Samsung Evo 970 500GB M.2 SSD.
The laptop had freedos installed on it's HDD.
When I got it I opened it up and installed the SSD right away. I then plugged in my Windows 10 installation USB stick and installed Windows on the SSD without problems.
When I tried to use the build in HDD though, I noticed it wasn't showing up in the explorer, so I checked Disk management and saw it was shown as unusable because it had freedos installed. Also Windows said it couldn't change anything about that Drive since it contained an OS.
I quickly looked it up on the internet (probably without doing enough research) and people said this could easily be fixed with a partition manager.
I installed one and decided to format the HDD since I would not need any of the data on it anymore anyways...

Everything looked fine until I tried switching it on again today and it keeps giving me the 'An operaring system wasn't found...' message.

I already checked my boot order, the SSD is set as the first priority.

I guess Windows did need that freedos on the other drive after all...any ideas what I can do now?

I am also away from home for half a year now so don't really have access to other computers too often...
 

dshort01

Distinguished
Feb 14, 2006
23
0
18,570
3
Why must things be so complicated? If the SSD does not have a boot sector a modern BIOS wont boot to it or even consider it as a possible boot device if there is not boot information. There is simply a problem with your installation to the M.2 device.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 3
B Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 2
M Laptop Tech Support 6
D Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 3
C Laptop Tech Support 2
T Laptop Tech Support 1
P Laptop Tech Support 1
P Laptop Tech Support 1
H Laptop Tech Support 1
R Laptop Tech Support 2
Y Laptop Tech Support 1
T Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 1
W Laptop Tech Support 1
R Laptop Tech Support 8

Similar threads


ASK THE COMMUNITY

TRENDING THREADS