Any new updates in resolving this issue? I'm experiencing this problem right now

hang-the-9

Titan
Moderator
That's a pretty new laptop, if it's in warranty, contact ASUS. If not in warranty, remove the battery, unplug wall power, hold in the power button for about 30 seconds. Plug in wall power only, no battery, try again. If that does not work, plug in battery and try it. If that also does not work, you need to have it looked at, maybe a bad charger, bad charging port or motherboard issue.
 

hang-the-9

Titan
Moderator
That's a pretty new laptop, if it's in warranty, contact ASUS. If not in warranty, remove the battery, unplug wall power, hold in the power button for about 30 seconds. Plug in wall power only, no battery, try again. If that does not work, plug in battery and try it. If that also does not work, you need to have it looked at, maybe a bad charger, bad charging port or motherboard issue.
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 2
B Laptop Tech Support 2
J Laptop Tech Support 0
Dropoff Laptop Tech Support 3
D Laptop Tech Support 1
E Laptop Tech Support 0
Zig_ZagDust1995 Laptop Tech Support 1
K Laptop Tech Support 2
badwwolfe Laptop Tech Support 0
Navneet Gautam Laptop Tech Support 13
S Laptop Tech Support 4
D Laptop Tech Support 0
SSorin Laptop Tech Support 0
I Laptop Tech Support 0
M Laptop Tech Support 0
aemerte Laptop Tech Support 0
X Laptop Tech Support 0
M Laptop Tech Support 0
D Laptop Tech Support 1
Z Laptop Tech Support 2

ASK THE COMMUNITY

TRENDING THREADS