Question Arc connection stop working

Feb 11, 2020
3
1
15
0
I have a Yamaha Advantage RX-A3070 hooked up to a LG G-7 TV. I have been running the TV to the receiver with the ARC connection with no issues for years. The other day I hooked up a Playstation 4 system and now have no video or sound through the ARC. I did not pull any cables out or change anything on the settings. I have tried new a cable, still have the same problem. I have hooked the receiver to a LG C-9 TV. I was able to get sound and video from the TV, but when I tried to use a game console, I don’t have any video. (yes it was on the right output) Anybody have any ideas what I am doing wrong. I am about to throw the whole system into the canal. Thanks for any help.
 
Feb 11, 2020
3
1
15
0
Thanks for the response back, All the TV settings and the setting for the receiver say ARC is on. I have checked the firmware on both and it is up to date. The PS4 is plugged into HDMI 3 with an Apple TV in 2 and Xbox in 1, none which work through the ARC connection Thanks again.
 
Feb 11, 2020
3
1
15
0
Fixed the problem, Didn't solve it. Did a factory reset on the receiver and now everything is working, (didn't think of this till today) Still don't know what happened. So if anybody has this same problem try the factory reset. Thanks. Peace out.
 
Reactions: helpstar
Thread starter Similar threads Forum Replies Date
G TVs 1
CronosS TVs 2
T TVs 5
T TVs 1
ReaperRSV TVs 4
Suechanges TVs 2
T TVs 1
M TVs 3
K TVs 0
Yungin0822 TVs 3
T TVs 1
S TVs 1
S TVs 1
M TVs 1
J TVs 1
EnDy_S TVs 2
Stormygeddon TVs 1
W TVs 1
A TVs 1
J TVs 1

ASK THE COMMUNITY