Asus Plugged In, Charging; stuck at 0%.

Renavan

Commendable
May 3, 2017
3
0
1,510
0
Hello everyone.

I bought a new Asus N550JX off of eBay recently. On arriving, I noticed the battery did not keep a charge, in fact, the laptop only worked with the charger plugged in.

I eventually bought another battery, but had the same issue. The laptop indicated that the battery was plugged in and charging, but remains at 0%.

I was able to flash the bios after much trouble, hopimg that would fix the problem, but that didn't change anything. I also did the whole procedure involving uninstalling the battery drivers, multiple times, but with no luck.

At this point, I'm wondering whether both batteries may be in 'sleep mode'. If that's the case, is it remotely possible to activate them by keeping the laptop plugged in for maybe 24 hours, or even 48? Thanks a lot.
 
Being the 'same information' doesn't mean the battery is good. Sadly many companies use substandard parts, and there can be other issues. The only way to know would be to try an OEM battery.

If it is still at 0 either the battery isn't good or perhaps the charging circuit has gone bad.
 
Question, was the battery you bought OEM or aftermarket? If aftermarket it may not be correct for the device. They are pretty much hit or miss when it comes to them working correctly.

However, it could actually be the charger cord. Try turning off the laptop. Not sleep or hibernate or just closing the lid, but actually turned off. Then plug it in to charge and see if it works. If it does, then the charger cord is probably the issue as when they are damaged they tend to not be putting out enough power to both run a device and charge the battery. Hence only able to charge when turned off.

Now if that doesn't make a difference and it still won't charge when turned off, then it is either the battery is not correct, or the charging circuit is damaged.
 

Renavan

Commendable
May 3, 2017
3
0
1,510
0
Thanks a lot for the quick response.
The battery I believe, is aftermarket, although it has the exact same information written on it as the OEM one, including the Asus logo. However, when I purchased it, I made sure the battery serials matched.

I've turned it off and will leave it to charge overnight. Hopefully I'll wake up to something good.

I'll get back to you in the morning with my results.
 

Renavan

Commendable
May 3, 2017
3
0
1,510
0
So after about 12 hours of the laptop charging without me using it, it's still at 0%.

I'm not sure what to do at this point. Unfortunately, where I live, sending it in to Asus is not an option.
 
Being the 'same information' doesn't mean the battery is good. Sadly many companies use substandard parts, and there can be other issues. The only way to know would be to try an OEM battery.

If it is still at 0 either the battery isn't good or perhaps the charging circuit has gone bad.
 
Thread starter Similar threads Forum Replies Date
ruslruslrusl1 Laptop Tech Support 3
S Laptop Tech Support 1
G Laptop Tech Support 1
T Laptop Tech Support 2
L Laptop Tech Support 0
alexdharriss Laptop Tech Support 2
A Laptop Tech Support 2
J Laptop Tech Support 1
T Laptop Tech Support 1
L Laptop Tech Support 1
C Laptop Tech Support 4
E Laptop Tech Support 1
A Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 1
R Laptop Tech Support 1
T Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 14
A Laptop Tech Support 1

ASK THE COMMUNITY