Solved! ASUS Zenbook UX390U show the White screen when I turn on.

Status
Not open for further replies.
First just try restarting (fully powering off and back on) the laptop. This may resolve the issue.

If it doesn't, then the next thing is to check the connections inside. Making sure that the cable that connects the display isn't pinched, damaged, loose, etc. If it seems OK, then I would replace the cable.

Should replacing the cable not resolve it, then I would look at replacing the display itself.
 
First just try restarting (fully powering off and back on) the laptop. This may resolve the issue.

If it doesn't, then the next thing is to check the connections inside. Making sure that the cable that connects the display isn't pinched, damaged, loose, etc. If it seems OK, then I would replace the cable.

Should replacing the cable not resolve it, then I would look at replacing the display itself.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Oneechan69 Laptop Tech Support 0
George Tzankov Laptop Tech Support 2
hansenb88 Laptop Tech Support 1
todel Laptop Tech Support 0
M Laptop Tech Support 4
G Laptop Tech Support 6
M Laptop Tech Support 1
F Laptop Tech Support 1
Zig_ZagDust1995 Laptop Tech Support 1
0_djek Laptop Tech Support 1
O Laptop Tech Support 1
Rata Laptop Tech Support 2
dooey123 Laptop Tech Support 2
S Laptop Tech Support 0
N Laptop Tech Support 1
J Laptop Tech Support 2
F Laptop Tech Support 0
FlamingoSteak Laptop Tech Support 0
Huema838 Laptop Tech Support 1
M Laptop Tech Support 1

ASK THE COMMUNITY