ASUS ZX53VW 15.6" No response from screen on initial boot

mateojcaro

Prominent
Apr 21, 2017
2
0
510
0
Hi, so recently i bought a ASUS ZX53VW 15.6" gaming laptop from amazon. It was a pretty good laptop considering the price and the reviews. I just got my laptop and was about to set it up, I pushed the power button and the back lit keyboard comes on and the light bulb indicator comes on( indicates if i have power). After about 30 minutes there was no response from the laptop. The screen remained black but the light indicators were still flashing and the keyboard still on. I tried it again and i am still greeted with a black screen. It is plugged into the wall and the battery indicator says it is charged. i haven't found anything online about this issue.

Images: https://drive.google.com/drive/folders/0B0F9yZzL7oxMMF9rcUJHMUpscHM?usp=sharing
Update: i plugged in an HDMI cable into the laptop and an external monitor. The set up screen pops up and appears okay but still no luck with the screen on the laptop.
 
Thread starter Similar threads Forum Replies Date
Serenitymcw Laptop Tech Support 2
M Laptop Tech Support 3
T Laptop Tech Support 5
P Laptop Tech Support 3
L Laptop Tech Support 7
S Laptop Tech Support 1
X Laptop Tech Support 1
C Laptop Tech Support 3
T Laptop Tech Support 2
R Laptop Tech Support 1
G Laptop Tech Support 1
S Laptop Tech Support 2
J Laptop Tech Support 5
R Laptop Tech Support 1
A Laptop Tech Support 3
S Laptop Tech Support 1
N Laptop Tech Support 1
R Laptop Tech Support 1
R Laptop Tech Support 1
M Laptop Tech Support 1

ASK THE COMMUNITY