Question Black screen after installing Intel HD Graphics 630 driver

Sep 9, 2019
3
0
10
0
The screen turns black as soon as Intel HD Graphics 630 drivers are updated.

All other drivers are installed and updated.


Everything works normally until the driver is being installed. During the installation process the screen goes black. The cursor does not appear and the keyboard is still lit.

Whenever i restarted the laptop, after the windows loading screen, the screen goes back to black. The solution is to enter safe mode and uninstall the HD Graphics 630 driver, therefore using the Microsoft Basic Video Adapter.

However, with this basic driver, the laptop performance drops in applications that require graphics processing, making it impractical to use in such situations.

I tried these possible solutions:
  • I tried to install several versions of the driver, which were available on the dell website itself or on the intel website, and all of them had a black screen during the installation.
  • I have also completely uninstalled the nvidia and intel drivers using DDU and tried to install hd graphics 630 drivers, but the black screen still persists.
  • Tried to update using the device manager. Same thing, screen still turns black.
  • I also tried to use an external monitor to see if there was video, the issue persists.
I already contacted dell and intell support, noboby seems to have a solution.

Laptop: Dell Inspiron 15 Gaming 7567
Windows 10 Pro version 1903
Bios version 1.10.0
Intel HD Graphics 630
NVIDIA GeForce GTX 1050 Ti
Intel Core i7-7700HQ
 
Sep 9, 2019
3
0
10
0
Getting the latest driver from dell site or intel site? or from windows update?
Already tried the latest Intel (v 26.20.100.7158) and dell (v 26.20.100.6859) drivers.

I disabled Windows Update because it was Installing the driver automatically and the screen was turning black after a few minutes, so it doesn't work too.
 
Sep 15, 2019
2
2
10
0
I have the exact same issue. I've tried old drivers and everything. Betting Windows update installed the new UHD drivers and hosed the Intel GPU. I've booted into safe mode and it shows up with the driver installed but the laptop monitor still runs on MS basic display adapter. I can't get certain apps to use my Nvidia settings. I can't use the HDMI port to set a second monitor and I can't access the Intel graphics control panel.
 
Reactions: dobermam
Sep 15, 2019
2
2
10
0
Oh and just a thought; this issue seems to have happened to quote a few people after the last big Windows update. I'm considering rolling back to the older windows 10 version, but don't have time right now. Have you tried this?
 
Reactions: dobermam
Sep 9, 2019
3
0
10
0
Oh and just a thought; this issue seems to have happened to quote a few people after the last big Windows update. I'm considering rolling back to the older windows 10 version, but don't have time right now. Have you tried this?
I tried. Rolled back to build 1809, but the issue persists, unfortunately.
 
Thread starter Similar threads Forum Replies Date
J Laptop Tech Support 3
B Laptop Tech Support 2
J Laptop Tech Support 4
H Laptop Tech Support 4
W Laptop Tech Support 2
A Laptop Tech Support 3
C Laptop Tech Support 2
J Laptop Tech Support 4
B Laptop Tech Support 3
G Laptop Tech Support 4
E Laptop Tech Support 2
Kevin McCutcheon Laptop Tech Support 3
R Laptop Tech Support 3
O Laptop Tech Support 5
B Laptop Tech Support 1
O Laptop Tech Support 1
R Laptop Tech Support 1
L Laptop Tech Support 3
T Laptop Tech Support 5
V Laptop Tech Support 2

ASK THE COMMUNITY