Question Blue Yeti X detected by G HUB but PC not picking up audio.

Status
Not open for further replies.
Jun 1, 2020
3
0
10
0
Hey everyone!

Here's what happened: I was using a pair of headphones that had a 3.5mm jack that splits into mic and headset audio. At this point, the Blue Yeti X i purchased worked just fine. I bought a new headset (Logitech G635) which plug in via USB or 3.5mm, but are only detecting on the PC and in G HUB when the USB is plugged in. All of a sudden, my Blue Yeti is saying "No input detected. Is your microphone muted?" in G HUB. My computer isnt detecting ANY sound from it, however, when i change settings on the mic (volume, gain, etc) it DOES change in the G HUB program. Also, if i set my headphones to 3.5mm jack and plug directly into the mic instead of the computer, i am able to hear the mic sound, and all volume adjustments made on the mic work. The PC and G HUB still do not pick up anything.
Ive done everything from not using any headphones, uninstalling and installing the mic through device manager, making sure the settings are correct and set as the default device. Nothing is working to rectify the problem. Any help would be amazing.
 

hang-the-9

Titan
Moderator
Did you check what the computer has set as the default mic input? If you have both the headset and Yeti is connected then the default may get set to the headset and need to change manually to the Yeti. Another question, if you are using a yeti mic why did you buy a headset with a mic instead of a better quality headphone only? You may want to think about using a better headphone vs that gaming headset if you won't be using the mic.
 
Jun 1, 2020
3
0
10
0
Did you check what the computer has set as the default mic input? If you have both the headset and Yeti is connected then the default may get set to the headset and need to change manually to the Yeti. Another question, if you are using a yeti mic why did you buy a headset with a mic instead of a better quality headphone only? You may want to think about using a better headphone vs that gaming headset if you won't be using the mic.
Great questions. I did mention at the end of my post that i had set it to the default, but no worries, my post was long and not structured very well. Also as i mentioned, even without the headset connected as well, and Yeti set to default as the Playback device, as well as the Recording device (Yeti is actually recognized as a sound card, and can relay all PC audio through it). Having said this, i have tried every combination of this set up; using the yeti as default playback or not. This made no difference. My computer still will not pick up the yeti audio, even tho it is still working to relay the audio to the headphones.

As for headphones, i just wanted the option to have the headphone mic if im using it for other reasons. I heard they were decent headphones and thought, why not. You're right in this scenario, its just not something i really put a ton of thought into before purchasing them. I really just needed a new headset and they seemed decent, not that my reasoning for wanting them really matters to my issue. At this point im glad i do have them, since i now have a usable mic with the Yeti not working.
 
Jun 1, 2020
3
0
10
0
OMG Finally someone else with the same problem. I have tried literally everything, have you found a fix for it?
Unfortunately, i did not find a fix for it, and returned the Mic. In hindsight, i wish i had looked into figuring out if it was in fact that since the Yeti has its own soundcard in it, it could have somehow been selecting my computer's sound card instead of the Yeti one or something. Not sure if thats even a real thing, but maybe there is a solution in there, somewhere.
If you end up figuring anything out, i would love to know the outcome. I'd like to get that mic again if there was a solution.
 
Jan 10, 2021
1
0
10
0
Open Sound Settings, Go to Manage Sound devices. Check and make sure both the Yeti Speaker and Yeti Microphone is enabled. I was having the same problem until I checked my output and inputs. If you have any of them disables, it'll show up as not connected or connecting on Ghub. I had my Yeti Mic on but the speaker off. My Yeti Mic was working and everything, but the speaker mode was disabled, it wasn't working with G Hub. After enabling it, it showed up on G Hub right away. Hope this works.
 
Status
Not open for further replies.
Thread starter Similar threads Forum Replies Date
Owl-Hoot Audio 3
S Audio 0
A Audio 1
E Audio 0
C Audio 1
coolguy76 Audio 1
HemoTalon Audio 0
tulumba Audio 0
swat14888 Audio 2
Bomberdawg Audio 1
DiabolusGX Audio 0
readbeancass Audio 2
H Audio 2
D Audio 1
Jasonary Audio 1
S Audio 5
Z Audio 2
E Audio 6
T Audio 1
B Audio 1

ASK THE COMMUNITY