Question Problem with my Blue Yeti (Classic) microphone?

Status
Not open for further replies.
Aug 14, 2021
2
0
10
0
My Blue Yeti (Classic) microphone keeps lowering/auto-compressing its volume while I'm talking; my voice sounds like a walkie talkie.

It was fine until a few days ago. Here's what I tried (Windows 10, btw):
  • Disconnected & reconnected it
  • Connected it to different USB ports
  • Ensured that the connections are tight and secure
  • Disabled all other recording devices
  • Disabled all Exclusive Mode options & Signal Enhancements
  • Disabled/exited Logitech G Hub
  • Rolled back drivers
I don't use Krisp or any noise suppression software (to my knowledge), but I do have Voicemeeter Banana - though even closing that didn't do anything. Why does it fade out when I speak for a few seconds at a time? Did the new driver update permanently screw up my microphone, or is there some program that's secretly messing with me for no reason at all (Logitech G and Blue Sherpa, for instance)? Or is it something else entirely?
 
Aug 14, 2021
2
0
10
0
Never mind, I found the solution!
Right-click the sound icon on the bottom-right taskbar > "Sound Control Panel" on the right side of the Settings window > "Recording" tab > click on "Yeti Classic"/"Yeti Stereo Microphone" > "Properties" button > "Properties" > "Change Settings" > "Driver" tab
From here, unplug the microphone, then click on "Uninstall Device." Once that's done, reconnect the microphone, and there should be no more auto-compression.
 
Status
Not open for further replies.

ASK THE COMMUNITY