Can't install operating system


Oct 2, 2015
I/we've bought a new laptop. It was with freedos operating system, to reduce costs. It had a HDD that was switched with an SDD. So I have an external HDD, an SSD and dvd-writer/reader inside. I wanted to put an OS on it by myself, as I'm studying IT.

I tried installing multiple os-es by usb, but it didn't seem to work.
I was unsuccessful downloading Linux Mint - it stuck just before the end, like 20-30 sec remaining.
Debian got stuck with a network thing I guess, as pc-s need to register by their mac on the network.
Sparkylinux worked from the usb, I was able to go on the internet (removing the utp cable from the Asus laptop wasn't easy though). The installation menu could be brought up, and I went to installation, partitioned the best I known (didn't do things like these before). After the message, install succesful and the prompt to restart the pc, only the usb version came up, without the usb only the "Reboot and Select proper Boot Device
or Insert Boot Media in selected Boot device and press a key" thing.
After going to the bios, I indeed saw something named "sparky", though I named one partition that, also. The installer correctly guessed the 240Gb volume of the SSD.
Ubuntu stuck(I should have waited more, yes, might try)
Versions of windows wanted cd/dvd.
I didn't format the usb, used the tool named Universal-USB-Installer to put the iso-s on the usb. The problem shouldn't be connected to this one.

There are two boot options in the bios:
sparky (P4: KINGSTON SV300S37A24OG)
I named the one sparky. [now there are three though]
There were two file-paths,
efi><sparky>grubia32.efi and grub.efi. if I pick them in the Save & Exit tab, nothing happens or the screen flashes, the third one goes (the same thing that comes out without an usb) to the "Reboot and..." phase.
It is ASUS X550JX XX016D laptop, with i5-4200h if that is needed. Though, the motherboard 'd be more important.

So this might make some people cringe, but in short, how do I install an OS?
Changes in the bios, if any, the serviceman talked about different settings for windows 7 and 8, I didn't know they might be picky about that or that they don't set it automatically.
Another little issue was that after certain tryings or shutdowns, a lamp on the laptop was lit with a light-bulb picture above it, and couldn't start it, could only do so by removing and reinserting the battery. Sata settings also said "AHCI", but that shouldn't be a problem, either.
What am I doing wrong, or I have to make an offering to the OS gods?


Hello vrforme

All that can be said about your first attempts is either the installation sources were faulty or the BIOS is not properly configured.

You may want to reset the BIOS settings to default and if this doesn't work, hard resetting your laptop may help.

To hard reset your laptop:

> Unplug it from the power adapter.

> Take out its battery.

> Press and hold the Power button for 45-60 seconds.

> Release the Power button.

> Put the battery back in and try installing the operating system this time.

If the above doesn't work either, you should take it to the vendor to get it replaced if it is still under the replacement period. If not, visiting an authorized service center to get the issue diagnosed would be your best bet.

Although you can also try clearing the CMOS by opening its back panel, the process violates the warranty of your computer which is something I would not suggest as your laptop is new.

Good Luck!!.
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 5
A Laptop Tech Support 2
L Laptop Tech Support 1
C Laptop Tech Support 5
A Laptop Tech Support 1
R Laptop Tech Support 2
B Laptop Tech Support 1
P Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 2
N Laptop Tech Support 13
W Laptop Tech Support 7
I Laptop Tech Support 2
S Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 1
K Laptop Tech Support 6
I Laptop Tech Support 29
B Laptop Tech Support 2
B Laptop Tech Support 1
Similar threads
Question Alienware 17 R2 can´t install operating system after wiping hard drive all I get is a black screen
An operating system wasn't found after installing Windows 10 to M.2 SSD
My acer laptop is not running an operating system have tried booting it with another operating system but it's not working
Solved! Dropped Laptop, new hard drive can't find drivers to install operating system
how to install and operating system on a new hard disk drive
Just installed new hard drive on HP laptop now getting boot device not found. Please install an operating system on your hard
wifi drivers installed and were working properly on my laptop HP with windows 7 64 bits operating system. But just over a sudd
Installing Linux on a Windows Laptop
Finding an operating system / installing
when i try to install an operating system it doesnt show a hard drive to install on ive switched hard drives doesnt make any d
Asus X751M Notebook Preinstalled Win 8 - Installing Windows 7 (Boot Loop)
How to install a operating system on my laptop
please, my iphone4s dropped on my hp laptop and the lap displays 'Boot Device not Found' please install an operating system. b
i change operating system of my packard bell then i installed driver pack 14 but touch pad isnt working please help
I cannot install any operating system
Cannot install operating system on hp 2000 tpn-i108 (and other issues)
Install operating system on a new hard drive
Installing Operating System [Serious] Help Please
An operating system wasn't found.
HELP CANT INSTALL NEW Operating system