Solved! Can't turn on wi-fi! after remove/replace the battery in Toshiba Radius L15W-B1320 laptop

Nov 13, 2018
1
0
10
0
I replaced the battery in Satellite Radius L15W-B1320 Now I can't turn on wi-fi!

You have to remove the back of the laptop to do this.

When I booted up after switching batteries, BIOS complained that the date/time was not set. After setting it and continuing into Windows 10 I find that the wi-fi is off and can't be turned on. I tried turning it on with: the tray wifi GUI, the network wifi GUI, f10, and TBSWireless.exe. In the settings\network\wifi GUI I can slide the switch from off->on, but it goes back to off when I come back to that menu. Switching airplane mode on/off doesn't help.

So, I could not get to the internet, but there happened to be a windows update ready so I let it try to install. After that the wifi worked. Great. But then I put the original battery back in and the same thing happened. No BIOS time and then no wi-fi.

Please, please, please, I need this for a long trip (why I was trying to have an extra battery). Any help or suggestions would be welcome. Can I offer money?

Michael

 

Saga Lout

Glorious
Moderator
OK, now for the problem. Something is loose in there.

Go back in and look for a very small square circuit board with two tiny wires connected to it.

That's the wireless card and my guess is that one of those wires is loose. Gently press on the little brass caps that connect the wire to the card.

In a quiet room you should hear a faint click as they connect. That should prevent the connections from breaking when you slip a battery back in.
 
Thread starter Similar threads Forum Replies Date
zy95 Laptop Tech Support 1
A Laptop Tech Support 0
Red Bandit Laptop Tech Support 13
Crazy_Grimold Laptop Tech Support 2
niv_p Laptop Tech Support 3
Z Laptop Tech Support 2
M Laptop Tech Support 1
D Laptop Tech Support 1
L Laptop Tech Support 1
D Laptop Tech Support 1
R Laptop Tech Support 2
D Laptop Tech Support 2
A Laptop Tech Support 1
S Laptop Tech Support 1
B Laptop Tech Support 1
R Laptop Tech Support 6
W Laptop Tech Support 1
G Laptop Tech Support 1
B Laptop Tech Support 2
B Laptop Tech Support 2

Similar threads


ASK THE COMMUNITY