Dell E1505 won't power on after BIOS update


Jul 10, 2012
I have an Inspiron E1505 laptop that has been working fine for as long as I remember. It runs Windows 7 Professional and every component seems to work.

Earlier today, I decided to update the BIOS. The stock BIOS was A06 and I updated to A17 using Dell's Windows utility. The system rebooted and a white update screen appeared. After that, the screen suddenly went black and the computer appeared to power off. It was plugged into AC power during the update. Now, whenever I press the Power button, the Numlock, Caps lock, and Scroll lock lights turn on along with the power light for 2 or 3 seconds and then the computer powers back off. None of the lights flash. All four simply glow for 2-3 seconds.

Nothing appears on the screen. I tried powering on with only AC power and no battery and with a battery but no AC power but the result is the same. I don't think the update utility has an issue since the same update worked through Windows 7 on another E1505 I have. The difference is that the laptop it worked on has a T2400 and 2GB RAM rather than a T2050 and 1GB.

Is there anything I should try to save the machine or am I screwed?